summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD28
-rw-r--r--wizorb.desktop12
-rw-r--r--wizorb.sh11
4 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7cb76ccc6aea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = wizorb-hib
+ pkgdesc = A retro-RPG themed breakout style game (Humble Bundle version)
+ pkgver = 1.1
+ pkgrel = 4
+ url = http://www.wizorb.com
+ arch = i686
+ arch = x86_64
+ license = custom:commercial
+ depends = mono
+ depends = openal
+ options = !strip
+ options = !upx
+ source = wizorb.sh
+ source = wizorb.desktop
+ sha512sums = 7ab7d83b7c99eafaee614832efa30b4f399eb0c62c47791ec9b3169eafe1195d4fdc9283c54190cf8aee916ec046b2557297d3c5000e732566ddf0f2efd8c8bb
+ sha512sums = 654dec6278d19d25440e74e7c850f3ab6f06c9af5ad39a7bf7dd8179234e1a3e763364e84aae7daab118db6b1a11d590bbe2621ff05fc7be40069f94bb97f331
+ source_i686 = hib://wizorb-32bit.tar.gz
+ sha512sums_i686 = b5997e9575c7339667c756d62893d0f20e264ca2cfda6383a3fa4a9ba2a40bfaaf943db5ebff4e73ae7f21624a83e3cfe7f7557b349e7b502282d00cf6959b91
+ source_x86_64 = hib://wizorb-64bit.tar.gz
+ sha512sums_x86_64 = c2ac71e97361e5b2eeaf547987a6de56df4663caf5b6d510b2db5a881ba5873ecb9ad4ba40c3dd8b91eebde5af5da60cdf16141c62fe009f0f43a88f15af7a05
+
+pkgname = wizorb-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee5019c4f015
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Kevin MacMartin <prurigro@gmail.com>
+# Adapted from the wizorb package contributed by TastyPi
+
+_pkgname=wizorb
+pkgname=$_pkgname-hib
+pkgver=1.1
+pkgrel=4
+pkgdesc='A retro-RPG themed breakout style game (Humble Bundle version)'
+url='http://www.wizorb.com'
+license=('custom:commercial')
+depends=('mono' 'openal')
+arch=('i686' 'x86_64')
+options=('!strip' '!upx')
+source=("$_pkgname.sh" "$_pkgname.desktop")
+sha512sums=('7ab7d83b7c99eafaee614832efa30b4f399eb0c62c47791ec9b3169eafe1195d4fdc9283c54190cf8aee916ec046b2557297d3c5000e732566ddf0f2efd8c8bb'
+ '654dec6278d19d25440e74e7c850f3ab6f06c9af5ad39a7bf7dd8179234e1a3e763364e84aae7daab118db6b1a11d590bbe2621ff05fc7be40069f94bb97f331')
+source_i686+=("hib://$_pkgname-32bit.tar.gz")
+source_x86_64+=("hib://$_pkgname-64bit.tar.gz")
+sha512sums_i686+=('b5997e9575c7339667c756d62893d0f20e264ca2cfda6383a3fa4a9ba2a40bfaaf943db5ebff4e73ae7f21624a83e3cfe7f7557b349e7b502282d00cf6959b91')
+sha512sums_x86_64+=('c2ac71e97361e5b2eeaf547987a6de56df4663caf5b6d510b2db5a881ba5873ecb9ad4ba40c3dd8b91eebde5af5da60cdf16141c62fe009f0f43a88f15af7a05')
+
+package() {
+ install -d "$pkgdir/opt"
+ cp -r $_pkgname "$pkgdir/opt/"
+ install -Dm755 $_pkgname.sh "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 $_pkgname.desktop "$pkgdir/usr/share/applications/$_pkgname.desktop"
+}
+
diff --git a/wizorb.desktop b/wizorb.desktop
new file mode 100644
index 000000000000..465c087ec160
--- /dev/null
+++ b/wizorb.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Icon=/opt/wizorb/wizorb.png
+Exec=wizorb
+Terminal=false
+StartupNotify=false
+
+Name=Wizorb
+Comment=An all-new block-breaking game set in a fantasy world.
+
+Categories=Game;ArcadeGame;
diff --git a/wizorb.sh b/wizorb.sh
new file mode 100644
index 000000000000..5ace120fa978
--- /dev/null
+++ b/wizorb.sh
@@ -0,0 +1,11 @@
+#!/usr/bin/env bash
+
+confdir="$HOME/.Tribute Games"
+
+[[ -d "$confdir" ]] || install -d "$confdir"
+[[ -h "$HOME/Tribute Games" ]] || ln -s "$confdir" "$HOME/Tribute Games"
+
+cd /opt/wizorb
+mono Wizorb.exe
+rm "$HOME/Tribute Games"
+