summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ee8d06f3902
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = wlhangul-git
+ pkgdesc = A Hangul input method for Wayland.
+ pkgver = r6.9fbe8d7
+ pkgrel = 1
+ url = https://github.com/emersion/wlhangul
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = meson
+ makedepends = git
+ depends = libhangul
+ depends = wayland
+ depends = libxkbcommon
+ provides = wlhangul
+ source = git+https://github.com/emersion/wlhangul.git
+ sha256sums = SKIP
+
+pkgname = wlhangul-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57001353351e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Songun Lee <leesongun@naver.com>
+
+pkgname=wlhangul-git
+_pkgname=wlhangul
+pkgver=r6.9fbe8d7
+pkgrel=1
+pkgdesc="A Hangul input method for Wayland."
+arch=('x86_64' 'i686')
+url="https://github.com/emersion/wlhangul"
+license=('MIT')
+depends=('libhangul' 'wayland' 'libxkbcommon')
+makedepends=('meson' 'git')
+provides=('wlhangul')
+source=('git+https://github.com/emersion/wlhangul.git')
+sha256sums=('SKIP')
+build() {
+ cd "$srcdir"/"$_pkgname"
+ meson build/
+ ninja -C build/
+}
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir"/"$_pkgname"
+ mkdir -p "$pkgdir"/usr/{bin,share,}
+ install -Dm755 "build/$_pkgname" "$pkgdir"/usr/bin
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
+