summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe7bfe3c6426..6cb3dcb362e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wllvm-git
pkgdesc = A wrapper script to build whole-program LLVM bitcode files
pkgver = r461.6d8955b
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/travitch/whole-program-llvm
arch = any
license = MIT
@@ -10,7 +10,7 @@ pkgbase = wllvm-git
depends = python
provides = wllvm
conflicts = wllvm
- source = wllvm-git::git+https://github.com/travitch/whole-program-llvm.git
+ source = wllvm-git::git+https://github.com/travitch/whole-program-llvm
md5sums = SKIP
pkgname = wllvm-git
diff --git a/PKGBUILD b/PKGBUILD
index 13d1328daebd..e0d4e1c593d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=wllvm-git
pkgver=r461.6d8955b
-pkgrel=2
+pkgrel=3
pkgdesc="A wrapper script to build whole-program LLVM bitcode files"
arch=('any')
url="https://github.com/travitch/whole-program-llvm"
@@ -11,12 +11,16 @@ depends=('python')
makedepends=('git' 'python-setuptools')
provides=('wllvm')
conflicts=('wllvm')
-source=("$pkgname"::'git+https://github.com/travitch/whole-program-llvm.git')
+source=("$pkgname"::'git+https://github.com/travitch/whole-program-llvm')
md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
- printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git describe --always)"
+ if git describe --long --tags >/dev/null 2>&1; then
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ else
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git describe --always)"
+ fi
}
build() {