summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..561c93b5e104
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = wmcompanion
+ pkgdesc = Desktop system event listener for minimal window manager users
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/kriansa/wmcompanion
+ arch = any
+ license = Apache
+ makedepends = python-poetry
+ makedepends = python-installer
+ depends = python
+ depends = python-dbus-next
+ source = https://github.com/kriansa/wmcompanion/archive/v0.1.1.tar.gz
+ sha256sums = 40cba25334bd04e52b7dd61c17daeb80cb67186108a98135e44877d7ab3204d1
+
+pkgname = wmcompanion
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d3939e732a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Daniel Pereira <daniel@garajau.com.br>
+
+pkgname=wmcompanion
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Desktop system event listener for minimal window manager users"
+url="https://github.com/kriansa/wmcompanion"
+arch=(any)
+license=(Apache)
+depends=(python python-dbus-next)
+makedepends=(python-poetry python-installer)
+source=("https://github.com/kriansa/wmcompanion/archive/v${pkgver}.tar.gz")
+sha256sums=(40cba25334bd04e52b7dd61c17daeb80cb67186108a98135e44877d7ab3204d1)
+
+build() {
+ cd "$pkgname-$pkgver" || exit 1
+ poetry build -f wheel
+}
+
+package() {
+ cd "$pkgname-$pkgver" || exit 1
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}