summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
-rw-r--r--list.patch15
3 files changed, 27 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be5b79763e18..292d164b50d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = wmcore
pkgdesc = A windowmaker dockapp which shows the usage of each core in the system
pkgver = 0.0.2
- pkgrel = 11
+ pkgrel = 12
url = http://web.archive.org/web/20121114121553/http://dockapps.windowmaker.org/file.php/id/362
arch = i686
arch = x86_64
license = GPL
depends = libxpm
source = wmcore-0.0.2.tar.gz
+ source = list.patch
md5sums = 26899aba55f84e649178ab8ab18f331e
+ md5sums = ce22a4016c93b0a1ee211e997f12a4e9
pkgname = wmcore
diff --git a/PKGBUILD b/PKGBUILD
index 385018109643..712c8a26cc5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=wmcore
pkgver=0.0.2
-pkgrel=11
+pkgrel=12
pkgdesc="A windowmaker dockapp which shows the usage of each core in the system"
arch=('i686' 'x86_64')
#url="http://dockapps.windowmaker.org/file.php/id/362"
@@ -13,28 +13,24 @@ url="http://web.archive.org/web/20121114121553/http://dockapps.windowmaker.org/f
license=('GPL')
depends=('libxpm')
#source=("http://dockapps.windowmaker.org/download.php/id/917/${pkgname}-${pkgver}.tar.gz")
-source=("${pkgname}-${pkgver}.tar.gz")
-md5sums=('26899aba55f84e649178ab8ab18f331e')
+source=("${pkgname}-${pkgver}.tar.gz" "list.patch")
+md5sums=('26899aba55f84e649178ab8ab18f331e'
+ 'ce22a4016c93b0a1ee211e997f12a4e9')
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
-
+ cd $pkgname-$pkgver
make clean
-
+ patch -Np2 -b -z .orig <../list.patch
}
build() {
-
- cd "$srcdir/$pkgname-$pkgver"
-
+ cd $pkgname-$pkgver
make
}
package() {
-
- cd "$srcdir/$pkgname-$pkgver"
-
- install -m 755 -D "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ cd $pkgname-$pkgver
+ install -m 755 -D "$pkgname" "$pkgdir/usr/bin/$pkgname"
if [[ -f "README" ]]; then
install -m 644 -D "README" "$pkgdir/usr/share/doc/$pkgname/README"
@@ -47,6 +43,5 @@ package() {
if [[ -f "COPYING" ]]; then
install -m 644 -D "COPYING" "$pkgdir/usr/share/doc/$pkgname/COPYING"
fi
-
}
diff --git a/list.patch b/list.patch
new file mode 100644
index 000000000000..a394842bccb3
--- /dev/null
+++ b/list.patch
@@ -0,0 +1,15 @@
+diff -up src/wmcore-0.0.2/list.h.orig src/wmcore-0.0.2/list.h
+--- src/wmcore-0.0.2/list.h.orig 2017-06-10 18:27:32.000000000 -0600
++++ src/wmcore-0.0.2/list.h 2017-06-10 18:27:41.000000000 -0600
+@@ -29,11 +29,7 @@ Boston, MA 02111-1307, USA. */
+ #ifndef __LIST_H_
+ #define __LIST_H_
+
+-#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
+-# define INLINE inline
+-#else
+ # define INLINE
+-#endif
+
+ typedef struct LinkedList {
+ void *head;