summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD42
2 files changed, 31 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 012668782f87..64273d168367 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = wmcore
pkgdesc = A windowmaker dockapp which shows the usage of each core in the system
pkgver = 0.0.2
- pkgrel = 3
+ pkgrel = 7
url = http://dockapps.windowmaker.org/file.php/id/362
arch = i686
arch = x86_64
groups = x11
license = GPL
depends = libxext
+ depends = libxpm
source = http://dockapps.windowmaker.org/download.php/id/917/wmcore-0.0.2.tar.gz
md5sums = 26899aba55f84e649178ab8ab18f331e
diff --git a/PKGBUILD b/PKGBUILD
index fbaf6e97f91f..015c909bee16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,48 @@
-# Maintainer: lspci <agm2819 at gmail dot com>
+# Maintainer: Alexej Magura <agm2819*gmail*com>
# Contributor: libernux <dutchman55l@gmx.com>
# Contributor: Brian Bidulock <bidulock@openss7.org>
pkgname=wmcore
pkgver=0.0.2
-pkgrel=3
+pkgrel=7
pkgdesc="A windowmaker dockapp which shows the usage of each core in the system"
arch=('i686' 'x86_64')
url="http://dockapps.windowmaker.org/file.php/id/362"
license=('GPL')
groups=('x11')
-depends=('libxext')
-source=("http://dockapps.windowmaker.org/download.php/id/917/$pkgname-$pkgver.tar.gz")
+depends=('libxext' 'libxpm')
+source=("http://dockapps.windowmaker.org/download.php/id/917/${pkgname}-${pkgver}.tar.gz")
md5sums=('26899aba55f84e649178ab8ab18f331e')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${srcdir}/${pkgname}-${pkgver}"
make clean
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
-# make install PREFIX="$pkgdir/usr/"
- mkdir -p $pkgdir/usr/bin
- mkdir -p $pkgdir/usr/share/doc/$pkgname
- install -c $pkgname $pkgdir/usr/bin/
- cd ..
-# install -c README $pkgdir/usr/share/doc/$pkgname/
- # --> Sorry, there doesn't seem to be a README file.
+ # get to the source :P
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # create the sub-dirs that the files-to-be-installed will be placed in.
+
+ mkdir -p "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/share/doc/${pkgname}"
+
+ # install the binary with 755 permissions
+
+ install -m 755 -T "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+
+ # install 'README', 'CHANGES', and 'COPYING' with 644 permissions.
+ # but only do this IF those files are present.
+
+ if [[ -f "README" ]]; then
+ install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}/" "README";
+ fi
+ if [[ -f "CHANGES" ]]; then
+ install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}/" "CHANGES";
+ fi
+ if [[ -f "COPYING" ]]; then
+ install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}/" "COPYING";
+ fi
}