summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD72
2 files changed, 41 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64273d168367..be5b79763e18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = wmcore
pkgdesc = A windowmaker dockapp which shows the usage of each core in the system
pkgver = 0.0.2
- pkgrel = 7
- url = http://dockapps.windowmaker.org/file.php/id/362
+ pkgrel = 11
+ url = http://web.archive.org/web/20121114121553/http://dockapps.windowmaker.org/file.php/id/362
arch = i686
arch = x86_64
- groups = x11
license = GPL
- depends = libxext
depends = libxpm
- source = http://dockapps.windowmaker.org/download.php/id/917/wmcore-0.0.2.tar.gz
+ source = wmcore-0.0.2.tar.gz
md5sums = 26899aba55f84e649178ab8ab18f331e
pkgname = wmcore
diff --git a/PKGBUILD b/PKGBUILD
index 015c909bee16..385018109643 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,52 @@
-# Maintainer: Alexej Magura <agm2819*gmail*com>
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Alexej Magura <agm2819*gmail*com>
# Contributor: libernux <dutchman55l@gmx.com>
# Contributor: Brian Bidulock <bidulock@openss7.org>
+
pkgname=wmcore
pkgver=0.0.2
-pkgrel=7
+pkgrel=11
pkgdesc="A windowmaker dockapp which shows the usage of each core in the system"
arch=('i686' 'x86_64')
-url="http://dockapps.windowmaker.org/file.php/id/362"
+#url="http://dockapps.windowmaker.org/file.php/id/362"
+url="http://web.archive.org/web/20121114121553/http://dockapps.windowmaker.org/file.php/id/362"
license=('GPL')
-groups=('x11')
-depends=('libxext' 'libxpm')
-source=("http://dockapps.windowmaker.org/download.php/id/917/${pkgname}-${pkgver}.tar.gz")
+depends=('libxpm')
+#source=("http://dockapps.windowmaker.org/download.php/id/917/${pkgname}-${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz")
md5sums=('26899aba55f84e649178ab8ab18f331e')
-
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make clean
+
+}
+
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make clean
- make
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make
}
package() {
- # get to the source :P
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- # create the sub-dirs that the files-to-be-installed will be placed in.
-
- mkdir -p "${pkgdir}/usr/bin"
- mkdir -p "${pkgdir}/usr/share/doc/${pkgname}"
-
- # install the binary with 755 permissions
-
- install -m 755 -T "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
-
- # install 'README', 'CHANGES', and 'COPYING' with 644 permissions.
- # but only do this IF those files are present.
-
- if [[ -f "README" ]]; then
- install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}/" "README";
- fi
- if [[ -f "CHANGES" ]]; then
- install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}/" "CHANGES";
- fi
- if [[ -f "COPYING" ]]; then
- install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}/" "COPYING";
- fi
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -m 755 -D "$pkgname" "$pkgdir/usr/bin/$pkgname"
+
+ if [[ -f "README" ]]; then
+ install -m 644 -D "README" "$pkgdir/usr/share/doc/$pkgname/README"
+ fi
+
+ if [[ -f "CHANGES" ]]; then
+ install -m 644 -D "CHANGES" "$pkgdir/usr/share/doc/$pkgname/CHANGES"
+ fi
+
+ if [[ -f "COPYING" ]]; then
+ install -m 644 -D "COPYING" "$pkgdir/usr/share/doc/$pkgname/COPYING"
+ fi
+
}