summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9584bca25006
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = wmforkplop
+ pkgdesc = A mixture between wmhdplop and the great wmtop.
+ pkgver = 0.9.3
+ pkgrel = 7
+ url = http://hules.free.fr/wmforkplop/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = imlib2
+ depends = libgtop>=2
+ source = http://hules.free.fr/wmforkplop/wmforkplop-0.9.3.tar.gz
+ md5sums = acee135833a4a5be5d31b8d01a7435ea
+
+pkgname = wmforkplop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04faa7ed6c9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor : Mathieu Pasquet <mathieuivi@gmail.com>
+pkgname=wmforkplop
+pkgver=0.9.3
+pkgrel=7
+pkgdesc="A mixture between wmhdplop and the great wmtop."
+arch=('i686' 'x86_64')
+url="http://hules.free.fr/wmforkplop/"
+license=(GPL)
+depends=('imlib2' 'libgtop>=2')
+source="http://hules.free.fr/wmforkplop/$pkgname-$pkgver.tar.gz"
+md5sums=('acee135833a4a5be5d31b8d01a7435ea')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i 's,imlib2-config --,pkg-config imlib2 --,' configure
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ # DESTDIR is buggy
+ make prefix=$pkgdir/usr install
+}