summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
-rw-r--r--inline.patch27
3 files changed, 48 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3c8a73969f5..957ea0beb798 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Tue May 3 14:41:23 UTC 2016
pkgbase = wmgtemp
pkgdesc = Dockapp to graphically display CPU and SYS temperatures.
pkgver = 1.1
- pkgrel = 3
+ pkgrel = 4
url = http://fluxcode.net/projects/wmgtemp
arch = i686
arch = x86_64
@@ -9,7 +11,9 @@ pkgbase = wmgtemp
depends = libxpm
depends = lm_sensors
source = http://fluxcode.net/files/wmgtemp-1.1.tar.gz
+ source = inline.patch
md5sums = cce700b3a4ef74b2ec019d8e89bdf2f6
+ md5sums = e9607a7259316854834b3ed4073697b7
pkgname = wmgtemp
diff --git a/PKGBUILD b/PKGBUILD
index 82e0899a6506..04baa53da99a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,31 @@
pkgname=wmgtemp
pkgver=1.1
-pkgrel=3
+pkgrel=4
pkgdesc="Dockapp to graphically display CPU and SYS temperatures."
url="http://fluxcode.net/projects/wmgtemp"
arch=('i686' 'x86_64')
license=('GPL2')
depends=('libxpm' 'lm_sensors')
-source=("http://fluxcode.net/files/wmgtemp-1.1.tar.gz")
+source=("http://fluxcode.net/files/wmgtemp-1.1.tar.gz"
+ inline.patch)
+md5sums=('cce700b3a4ef74b2ec019d8e89bdf2f6'
+ 'e9607a7259316854834b3ed4073697b7')
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -Np2 -b -z .orig -i ../inline.patch
+}
+
build() {
-cd "$srcdir/$pkgname-$pkgver"
-sed -i "/MANINSTDIR=/d" Makefile
-make PREFIX="/usr"
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i "/MANINSTDIR=/d" Makefile
+ make PREFIX="/usr"
}
package() {
-cd "$srcdir/$pkgname-$pkgver"
-install -d "$pkgdir/usr/bin"
-make INSTDIR="$pkgdir/usr/bin" MANINSTDIR="$pkgdir/usr/share/man/man1" install
+ cd "$srcdir/$pkgname-$pkgver"
+ install -d "$pkgdir/usr/bin"
+ make INSTDIR="$pkgdir/usr/bin" MANINSTDIR="$pkgdir/usr/share/man/man1" install
}
-
-md5sums=('cce700b3a4ef74b2ec019d8e89bdf2f6')
diff --git a/inline.patch b/inline.patch
new file mode 100644
index 000000000000..56a0655b78d0
--- /dev/null
+++ b/inline.patch
@@ -0,0 +1,27 @@
+diff -up src/wmgtemp-1.1/src/wmgeneral/list.h.orig src/wmgtemp-1.1/src/wmgeneral/list.h
+--- src/wmgtemp-1.1/src/wmgeneral/list.h.orig 2016-05-03 08:38:13.000000000 -0600
++++ src/wmgtemp-1.1/src/wmgeneral/list.h 2016-05-03 08:38:24.000000000 -0600
+@@ -29,11 +29,7 @@ Boston, MA 02111-1307, USA. */
+ #ifndef __LIST_H_
+ #define __LIST_H_
+
+-#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
+-# define INLINE inline
+-#else
+ # define INLINE
+-#endif
+
+ typedef struct LinkedList {
+ void *head;
+diff -up src/wmgtemp-1.1/src/wmgtemp.c.orig src/wmgtemp-1.1/src/wmgtemp.c
+--- src/wmgtemp-1.1/src/wmgtemp.c.orig 2016-05-03 08:36:54.000000000 -0600
++++ src/wmgtemp-1.1/src/wmgtemp.c 2016-05-03 08:37:05.000000000 -0600
+@@ -20,6 +20,8 @@
+ #include <signal.h>
+ #include <getopt.h>
+
++#define inline
++
+ /* Defines */
+ #define BitOff(a,x) ((void)((a) &= ~(1 << (x))))
+ #define BitOn(a,x) ((void)((a) |= (1 << (x))))