summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b5933cd1730
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = wmmand
+ pkgdesc = Mandelbrot set browser docapp for Window Maker
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = http://github.com/ciotog/wmMand
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = libxpm
+ source = wmmand::git+https://github.com/ciotog/wmMand.git
+ md5sums = SKIP
+
+pkgname = wmmand
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88a223c85531
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+pkgname=wmmand
+pkgver=1.3.2
+pkgrel=1
+pkgdesc="Mandelbrot set browser docapp for Window Maker"
+arch=('i686' 'x86_64')
+url="http://github.com/ciotog/wmMand"
+license=('GPL')
+depends=('libxpm')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/ciotog/wmMand.git")
+md5sums=('SKIP')
+
+prepare() {
+ cd $pkgname/wmMand
+ gunzip wmMand.6.gz
+}
+
+build() {
+ cd $pkgname
+ make
+}
+
+package() {
+ cd $pkgname/wmMand
+ install -Dm0755 wmMand "$pkgdir/usr/bin/wmMand"
+ install -Dm0644 wmMand.6 "$pkgdir/usr/share/man/man6/wmMand.6"
+ install -Dm0644 wmMand.png "$pkgdir/usr/share/pixmaps/wmMand.png"
+}
+