summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1cd151e7a073
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wmmatrix
+ pkgdesc = Dock app that simulates the text scrolls from the movie "The Matrix"
+ pkgver = 0.2
+ pkgrel = 1
+ url = http://nis-www.lanl.gov/~mgh/WindowMaker/DockApps.shtml
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libxpm
+ source = http://gentoo.osuosl.org/distfiles/wmMatrix-0.2.tar.gz
+ md5sums = 4e9f0c94e78ad65ea9a564fba5f7a187
+
+pkgname = wmmatrix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca77684e10f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+
+pkgname=wmmatrix
+_pkgname=wmMatrix
+pkgver=0.2
+pkgrel=1
+pkgdesc="Dock app that simulates the text scrolls from the movie \"The Matrix\""
+url="http://nis-www.lanl.gov/~mgh/WindowMaker/DockApps.shtml"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('libxpm')
+source=("http://gentoo.osuosl.org/distfiles/$_pkgname-$pkgver.tar.gz")
+md5sums=('4e9f0c94e78ad65ea9a564fba5f7a187')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make clean
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ install -Dm0755 wmMatrix "$pkgdir/usr/bin/wmMatrix"
+}
+
+# vim: set sw=2 et: