summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD21
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86116df1f15e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wmrc
+ pkgdesc = WMRC is a shell utility for extending window manager capabilities using modules with dependency and error checking.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/filiparag/wmrc
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = dash
+ source = git+https://github.com/filiparag/wmrc.git
+ sha1sums = SKIP
+
+pkgname = wmrc
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..0384473f40a9
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2020 Filip Parag
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8377a192a17a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Filip Parag <aur@filiparag.com>
+
+pkgname=wmrc
+pkgver=1.0
+pkgrel=1
+pkgdesc='WMRC is a shell utility for extending window manager capabilities using modules with dependency and error checking.'
+arch=('any')
+url='https://github.com/filiparag/wmrc'
+license=('MIT')
+depends=('dash')
+makedepends=('git')
+source=('git+https://github.com/filiparag/wmrc.git')
+sha1sums=('SKIP')
+
+package() {
+ cd "${pkgname}"
+ install -Dm 775 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -d -m 775 "${pkgdir}/usr/share/${pkgname}"
+ install -Dm 664 "rc.conf" "${pkgdir}/usr/share/${pkgname}/"
+ cp -r --preserve=mode "modules" "${pkgdir}/usr/share/${pkgname}/"
+} \ No newline at end of file