summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD26
2 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94db92cb131b..e64a46d54d14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = wmrc
pkgdesc = WMRC is a shell utility for extending window manager capabilities using modules with dependency and error checking.
pkgver = 1.1
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/filiparag/wmrc
arch = any
license = MIT
- makedepends = git
depends = dash
- source = git+https://github.com/filiparag/wmrc.git
- sha1sums = SKIP
+ source = wmrc-1.1.tar.gz::https://github.com/filiparag/wmrc/archive/1.1.tar.gz
+ sha256sums = ee6bfdac42cc5d7e30e7af593ada869ce71a33a9cb8cc9bcb22040ac044c7bfc
pkgname = wmrc
diff --git a/PKGBUILD b/PKGBUILD
index 7b5a5258a560..a74e13a43cbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,25 @@
pkgname=wmrc
pkgver=1.1
-pkgrel=5
+pkgrel=6
pkgdesc='WMRC is a shell utility for extending window manager capabilities using modules with dependency and error checking.'
arch=('any')
url='https://github.com/filiparag/wmrc'
license=('MIT')
depends=('dash')
-makedepends=('git')
-source=('git+https://github.com/filiparag/wmrc.git')
-sha1sums=('SKIP')
-
-prepare() {
- cd "${pkgname}"
- git checkout "tags/${pkgver}"
-}
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('ee6bfdac42cc5d7e30e7af593ada869ce71a33a9cb8cc9bcb22040ac044c7bfc')
package() {
- cd "${pkgname}"
+
+ cd "${pkgname}-${pkgver}"
+
install -Dm 755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -d -m 755 "${pkgdir}/usr/share/${pkgname}"
- install -Dm 644 "rc.conf" "${pkgdir}/usr/share/${pkgname}/"
- install -Dm 644 "usage.txt" "${pkgdir}/usr/share/${pkgname}/"
- install -Dm 644 "wmrc.man" "${pkgdir}/usr/share/man/man1/${pkgname}.${pkgver}"
+
+ install -Dm 644 'wmrc.man' "${pkgdir}/usr/share/man/man1/${pkgname}.1"
+ install -Dm 644 'LICENSE' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ install -Dm 644 -t "${pkgdir}/usr/share/${pkgname}" 'rc.conf' 'usage.txt'
cp -r --preserve=mode "modules" "${pkgdir}/usr/share/${pkgname}/"
+
} \ No newline at end of file