summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--list.patch15
3 files changed, 30 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afb50ab3c91c..c42c3b9c5b1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon May 2 02:51:36 UTC 2016
pkgbase = wmtime
pkgdesc = Analog/digital clock dockapp for Window Maker
pkgver = 1.0b2
- pkgrel = 3
+ pkgrel = 4
url = http://web.cs.mun.ca/~gstarkes/wmaker/dockapps/time.html#wmtime
arch = i686
arch = x86_64
license = GPL
depends = libxpm
source = http://web.cs.mun.ca/~gstarkes/wmaker/dockapps/files/wmtime-1.0b2.tar.gz
+ source = list.patch
md5sums = 04c03e001aa702cf653b6b6c3f58bf87
+ md5sums = 721d65fc76d1985133d2dcfaf604d7b3
pkgname = wmtime
diff --git a/PKGBUILD b/PKGBUILD
index ceb8420b4e04..0c771d2e67a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,21 @@
# Contributor: Henrik Tunedal <henrik at tunedal dot nu>
pkgname=wmtime
pkgver=1.0b2
-pkgrel=3
+pkgrel=4
pkgdesc="Analog/digital clock dockapp for Window Maker"
arch=('i686' 'x86_64')
url="http://web.cs.mun.ca/~gstarkes/wmaker/dockapps/time.html#wmtime"
license=('GPL')
depends=('libxpm')
-source=("http://web.cs.mun.ca/~gstarkes/wmaker/dockapps/files/$pkgname-$pkgver.tar.gz")
-md5sums=('04c03e001aa702cf653b6b6c3f58bf87')
+source=("http://web.cs.mun.ca/~gstarkes/wmaker/dockapps/files/$pkgname-$pkgver.tar.gz"
+ list.patch)
+md5sums=('04c03e001aa702cf653b6b6c3f58bf87'
+ '721d65fc76d1985133d2dcfaf604d7b3')
+
+prepare() {
+ cd "$srcdir/wmtime.app"
+ patch -Np2 -b -z .orig -i ../list.patch
+}
build() {
cd "$srcdir/wmtime.app/wmtime"
diff --git a/list.patch b/list.patch
new file mode 100644
index 000000000000..7902f86c2c4e
--- /dev/null
+++ b/list.patch
@@ -0,0 +1,15 @@
+diff -up src/wmtime.app/wmgeneral/list.h.orig src/wmtime.app/wmgeneral/list.h
+--- src/wmtime.app/wmgeneral/list.h.orig 2016-05-01 20:48:08.000000000 -0600
++++ src/wmtime.app/wmgeneral/list.h 2016-05-01 20:48:15.000000000 -0600
+@@ -29,11 +29,7 @@ Boston, MA 02111-1307, USA. */
+ #ifndef __LIST_H_
+ #define __LIST_H_
+
+-#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
+-# define INLINE inline
+-#else
+ # define INLINE
+-#endif
+
+ typedef struct LinkedList {
+ void *head;