summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD27
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b1910d02e21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = wofi-pass-git
+ pkgdesc = A Wayland-native interface for conveniently using pass
+ pkgver = r26.869c545
+ pkgrel = 1
+ url = https://github.com/TinfoilSubmarine/wofi-pass
+ arch = any
+ license = GPL
+ depends = coreutils
+ depends = findutils
+ depends = grep
+ depends = man-pages
+ depends = pass
+ depends = tcl
+ depends = util-linux
+ depends = wl-clipboard
+ depends = wofi
+ optdepends = wtype: type support
+ optdepends = pass-otp: OTP support
+ source = git+https://github.com/TinfoilSubmarine/wofi-pass.git
+ sha512sums = SKIP
+
+pkgname = wofi-pass-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4b1128d55457
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+wofi-pass/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb02d395f5c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: noobping <hello@noobping.dev>
+
+pkgname=wofi-pass-git
+_pkgname=${pkgname%-git}
+pkgver=VERSION
+pkgrel=1
+pkgdesc="A Wayland-native interface for conveniently using pass"
+arch=('any')
+url='https://github.com/TinfoilSubmarine/wofi-pass'
+license=('GPL')
+depends=('coreutils' 'findutils' 'grep' 'man-pages' 'pass' 'tcl' 'util-linux' 'wl-clipboard' 'wofi')
+optdepends=(
+ 'wtype: type support'
+ 'pass-otp: OTP support')
+source=("git+${url}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -Dm755 "${_pkgname}" -t "${pkgdir}/usr/bin"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}