summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
-rw-r--r--wofi-wifi-menu.install7
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..53625db3bb3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = wofi-wifi-menu-git
+ pkgdesc = bash script providing WiFi menu for wofi
+ pkgver = 25.30e42e6
+ pkgrel = 1
+ url = https://github.com/fourstepper/wofi-wifi-menu
+ install = wofi-wifi-menu.install
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = wofi
+ depends = networkmanager
+ depends = bc
+ depends = wireless_tools
+ provides = wofi-wifi-menu
+ conflicts = wofi-wifi-menu
+ source = git+https://github.com/fourstepper/wofi-wifi-menu
+ sha256sums = SKIP
+
+pkgname = wofi-wifi-menu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c96678a8578
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Robin Opletal <fourstepper@users.noreply.github.com>
+# Contributor: Charlie Haley <charlie-haley@users.noreply.github.com>
+pkgname=wofi-wifi-menu-git
+_pkgname=wofi-wifi-menu
+pkgver=25.30e42e6
+pkgrel=1
+pkgdesc="bash script providing WiFi menu for wofi"
+arch=('any')
+url='https://github.com/fourstepper/wofi-wifi-menu'
+license=('unknown')
+install=wofi-wifi-menu.install
+depends=('wofi' 'networkmanager' 'bc' 'wireless_tools')
+makedepends=('git')
+source=('git+https://github.com/fourstepper/wofi-wifi-menu')
+sha256sums=('SKIP')
+provides=('wofi-wifi-menu')
+conflicts=('wofi-wifi-menu')
+
+pkgver() {
+ cd ${_pkgname}
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm755 "$srcdir/$_pkgname/wofi-wifi-menu.sh" "$pkgdir/usr/bin/wofi-wifi-menu"
+ install -Dm555 "$srcdir/$_pkgname/config.example" "$pkgdir/usr/share/wofi/wifi.example"
+}
diff --git a/wofi-wifi-menu.install b/wofi-wifi-menu.install
new file mode 100644
index 000000000000..59571a914259
--- /dev/null
+++ b/wofi-wifi-menu.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo 'To configure wofi-wifi-menu copy:'
+ echo ' /usr/share/wofi/wifi.example'
+ echo 'to'
+ echo ' ~/.config/wofi/wifi'
+ echo 'and modify it.'
+}