summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9963e4eb81e3..2bec635865a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = woodpecker-agent-sudo
pkgdesc = A simple CI engine with great extensibility (agent), patched to use sudo to run local pipelines
pkgver = 1.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://woodpecker-ci.org
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index ebfaaa5524e2..aaa9e31fb5a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname='woodpecker-agent'
pkgname=$_pkgname-sudo
pkgver=1.0.2
-pkgrel=1
+pkgrel=2
pkgdesc='A simple CI engine with great extensibility (agent), patched to use sudo to run local pipelines'
arch=('x86_64')
url='https://woodpecker-ci.org'
@@ -66,7 +66,7 @@ build() {
export CGO_CXXFLAGS="${CXXFLAGS}"
export GOPATH="${srcdir}"
- # build server/agent/cli
+ # build agent
go build -v \
-buildmode=pie \
-mod=readonly \
@@ -76,6 +76,8 @@ build() {
-extldflags ${LDFLAGS}" \
-o build \
./cmd/agent
+
+ go clean -modcache
}
package() {