summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 7 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 704c46ab4b40..3fa36a77601c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = woof
license = GPL2
depends = python2
conflicts = woof-python3
- source = http://www.home.unix-ag.org/simon/woof-2012-05-31.py
+ source = http://www.home.unix-ag.org/simon/woof
md5sums = 89081e64362421dcb683a19c10a15e59
pkgname = woof
diff --git a/PKGBUILD b/PKGBUILD
index 6c5fac47b581..828daef56c08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
-# $Id: PKGBUILD 26387 2010-09-15 10:52:53Z cbrannon $
-# Maintainer: Andreas B. Wagner <AndreasBWagner@pointfree.net>
-# Maintainer: Aaron Schaefer <aaron@elasticdog.com>
+# Maintainer: dacoit <dacoit at tuta.io>
+# Contributor: Andreas B. Wagner <AndreasBWagner@pointfree.net>
+# Contributor: Aaron Schaefer <aaron@elasticdog.com>
# Contributor: Evan Gates <evan.gates at gmail dot com>
# Contributor: Vardyr <vardyr.al at insocada dot com>
pkgname=woof
pkgver=20120531
-_pkgver='2012-05-31'
pkgrel=1
pkgdesc='An ad-hoc single file webserver; Web Offer One File'
arch=('any')
@@ -14,17 +13,10 @@ url='http://www.home.unix-ag.org/simon/woof.html'
license=('GPL2')
depends=('python2')
conflicts=('woof-python3')
-source=("http://www.home.unix-ag.org/simon/$pkgname-$_pkgver.py")
+source=("http://www.home.unix-ag.org/simon/$pkgname")
md5sums=('89081e64362421dcb683a19c10a15e59')
-build() {
- /bin/true
-}
-
package() {
- cd "$srcdir"
-
- install -D -m755 "$pkgname-$_pkgver.py" "$pkgdir/usr/bin/$pkgname"
- sed -i -e 's,^#!/usr/bin/env python$,#!/usr/bin/env python2,' \
- "$pkgdir/usr/bin/$pkgname"
+ sed -i -e 's,^#!/usr/bin/env python$,#!/usr/bin/env python2,' "$pkgname"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
}