summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Fall-back-to-OPL-on-MIDI-initialization-failure.patch30
-rw-r--r--PKGBUILD9
3 files changed, 8 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fca2775ec28b..e650d994f41d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = woof-doom
pkgdesc = Woof! is a continuation of Lee Killough's Doom source port MBF targeted at modern systems
pkgver = 11.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/fabiangreffrath/woof
install = install.sh
arch = x86_64
@@ -17,8 +17,8 @@ pkgbase = woof-doom
optdepends = soundfont-fluid: soundfont for MIDI playback
conflicts = woof-git
source = https://github.com/fabiangreffrath/woof/archive/refs/tags/woof_11.0.0.tar.gz
- source = 0001-Fall-back-to-OPL-on-MIDI-initialization-failure.patch
+ source = https://github.com/fabiangreffrath/woof/commit/8eb510840f0b510af3bf5a0cd79bb6d2e1cd2474.patch
sha256sums = 434f78fefb24a99a1dd693e67f8587d4b4c0ad0c2e3e97073ef8ef563a95bd05
- sha256sums = 7d5bd6a9de3acbfccbd88c1639902360fd4b79f53ae230af8b742d839b6ab4c0
+ sha256sums = 3c69a746a61ca55716d84f4224f381b6f37cc621a4b191c3caa0780c9bbcdd3e
pkgname = woof-doom
diff --git a/0001-Fall-back-to-OPL-on-MIDI-initialization-failure.patch b/0001-Fall-back-to-OPL-on-MIDI-initialization-failure.patch
deleted file mode 100644
index fca08228423c..000000000000
--- a/0001-Fall-back-to-OPL-on-MIDI-initialization-failure.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 4faf013f2237743819a3a702c7e2dbb217e8c79f Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Joan=20Bruguera=20Mic=C3=B3?= <joanbrugueram@gmail.com>
-Date: Thu, 4 May 2023 19:05:22 +0000
-Subject: [PATCH] Fall back to OPL on MIDI initialization failure
-
-If the user doesn't have any sound fonts, FluidSynth initialization will fail.
-Falling back to 'module 0' will fall back to FluidSynth again, which will fail
-again and Woof! will ultimately crash.
-
-Should be fixed upstream but patching on Arch package due to impact.
----
- src/i_sound.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/i_sound.c b/src/i_sound.c
-index 60c8199..6176d16 100644
---- a/src/i_sound.c
-+++ b/src/i_sound.c
-@@ -704,7 +704,7 @@ static void MidiPlayerFallback(void)
- {
- // Fall back to module 0 device 0.
- midi_player = 0;
-- midi_player_module = music_modules[0].module;
-+ midi_player_module = &music_opl_module;
- midi_player_module->I_InitMusic(0);
- active_module = midi_player_module;
- }
---
-2.40.1
-
diff --git a/PKGBUILD b/PKGBUILD
index a883d03a4d50..9c15f25bbfc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=woof-doom
_pkgname=woof
pkgver=11.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Woof! is a continuation of Lee Killough's Doom source port MBF targeted at modern systems"
arch=(x86_64)
url="https://github.com/fabiangreffrath/woof"
@@ -20,10 +20,11 @@ conflicts=(woof-git)
source=("https://github.com/fabiangreffrath/${_pkgname}/archive/refs/tags/${_pkgname}_${pkgver}.tar.gz")
sha256sums=(434f78fefb24a99a1dd693e67f8587d4b4c0ad0c2e3e97073ef8ef563a95bd05)
-source+=(0001-Fall-back-to-OPL-on-MIDI-initialization-failure.patch)
-sha256sums+=(7d5bd6a9de3acbfccbd88c1639902360fd4b79f53ae230af8b742d839b6ab4c0)
+# fix crash on Linux+FluidSynth w/no soundfonts: https://github.com/fabiangreffrath/woof/pull/1035
+source+=(https://github.com/fabiangreffrath/woof/commit/8eb510840f0b510af3bf5a0cd79bb6d2e1cd2474.patch)
+sha256sums+=(3c69a746a61ca55716d84f4224f381b6f37cc621a4b191c3caa0780c9bbcdd3e)
prepare() {
- patch -d "${_pkgname}-${_pkgname}_${pkgver}" -Np1 -i ../0001-Fall-back-to-OPL-on-MIDI-initialization-failure.patch
+ patch -d "${_pkgname}-${_pkgname}_${pkgver}" -Np1 -i ../8eb510840f0b510af3bf5a0cd79bb6d2e1cd2474.patch
}
build() {