summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore8
-rw-r--r--.nvchecker.toml4
-rw-r--r--70-wooting.rules26
-rw-r--r--PKGBUILD52
-rw-r--r--wootility-appimage.install6
6 files changed, 67 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20dff17dcd04..6f380e084cef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = wootility-appimage
pkgdesc = Utility for configuring Wooting keyboards (binary AppImage version)
- pkgver = 3.4.5
+ pkgver = 4.6.18
pkgrel = 1
url = https://wooting.io/wootility
install = wootility-appimage.install
arch = x86_64
+ arch = x86_64_v3
license = unknown
- makedepends = p7zip
+ makedepends = util-linux
+ makedepends = findutils
depends = fuse2
provides = wootility
+ provides = wootility-lekker
conflicts = wootility
- noextract = wootility-3.4.5.AppImage
options = !strip
- source = https://s3.eu-west-2.amazonaws.com/wooting-update/wootility-linux-latest/wootility-3.4.5.AppImage
+ source = https://s3.eu-west-2.amazonaws.com/wooting-update/wootility-lekker-linux-latest/wootility-lekker-4.6.18.AppImage
source = 70-wooting.rules
- sha512sums = 27db389e5c31624c163dd6c7b4fb8624758cd2fbf0e10116d96511dde03aeb88a8e22423ffb584e3d042aa92e13ec703a15243daf469604ac7fb56dfc8465173
- sha512sums = 3a569cb1292efc31e22fd6c425fff14ac98d7f280849b3d81cdd72523a3388e6623bcd026571f726656fb339f9b90527efd8829d82de1d0b1ac778921dd72633
+ b2sums = 6154ed86c7d655955baf976aaec307c1a4ebb0466a8c377e2d1325e88f4f11362d423cc9666c117d96e387c5458fd1ac073687a06199437f0414533088648e9c
+ b2sums = 80b4a516f8aafb6eada36cdde59295f2358b22e6cc28b1a21b0b5f22a59bcfabc63bba956d23544faca5fd76a1c4b4c1ff98ada41e7c9ad015d48c7c436dbac1
pkgname = wootility-appimage
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e58b2f8fa164
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!*.rules
+!*.install
+!*.service
+!.nvchecker.toml
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..3939ca122fcb
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,4 @@
+[wootility-appimage]
+source = "httpheader"
+url = "https://api.wooting.io/public/wootility/download?os=linux&branch=lekker"
+regex = "wootility-lekker-((?:\\d|\\.)+)\\.AppImage"
diff --git a/70-wooting.rules b/70-wooting.rules
index aa5391ff1f52..2ea36da2b730 100644
--- a/70-wooting.rules
+++ b/70-wooting.rules
@@ -1,17 +1,15 @@
-SUBSYSTEM=="input", GROUP="input", MODE="0660"
-
-# Wooting One
-SUBSYSTEM=="usb*", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="ff01", TAG+="uaccess"
-SUBSYSTEM=="hid*", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="ff01", TAG+="uaccess"
-
+# Wooting One Legacy
+SUBSYSTEM=="hidraw", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="ff01", TAG+="uaccess"
+SUBSYSTEM=="usb", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="ff01", TAG+="uaccess"
# Wooting One update mode
-SUBSYSTEM=="usb*", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="2402", TAG+="uaccess"
-SUBSYSTEM=="hid*", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="2402", TAG+="uaccess"
-
-# Wooting Two
-SUBSYSTEM=="usb*", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="ff02", TAG+="uaccess"
-SUBSYSTEM=="hid*", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="ff02", TAG+="uaccess"
+SUBSYSTEM=="hidraw", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="2402", TAG+="uaccess"
+# Wooting Two Legacy
+SUBSYSTEM=="hidraw", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="ff02", TAG+="uaccess"
+SUBSYSTEM=="usb", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="ff02", TAG+="uaccess"
# Wooting Two update mode
-SUBSYSTEM=="usb*", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="2403", TAG+="uaccess"
-SUBSYSTEM=="hid*", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="2403", TAG+="uaccess"
+SUBSYSTEM=="hidraw", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="2403", TAG+="uaccess"
+
+# Generic Wootings
+SUBSYSTEM=="hidraw", ATTRS{idVendor}=="31e3", TAG+="uaccess"
+SUBSYSTEM=="usb", ATTRS{idVendor}=="31e3", TAG+="uaccess"
diff --git a/PKGBUILD b/PKGBUILD
index dc3e77faf656..30ce8dcfad0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,53 @@
# Maintainer: Frederik “Freso” S. Olesen <archlinux@freso.dk>
+# Contributor: Shayne Hartford <shayneehartford@gmail.com>
+
_pkgname=wootility
pkgname=${_pkgname}-appimage
-pkgver=3.4.5
+pkgver=4.6.18
pkgrel=1
pkgdesc='Utility for configuring Wooting keyboards (binary AppImage version)'
-arch=('x86_64')
+arch=('x86_64' 'x86_64_v3')
url='https://wooting.io/wootility'
license=('unknown')
depends=('fuse2')
-makedepends=('p7zip')
-provides=("${_pkgname}")
+makedepends=('util-linux' 'findutils')
+provides=("${_pkgname}" "${_pkgname}-lekker")
conflicts=("${_pkgname}")
options=(!strip)
-_appimage="${_pkgname}-${pkgver}.AppImage"
+_appimage="${_pkgname}-lekker-${pkgver}.AppImage"
install=$pkgname.install
-source=("https://s3.eu-west-2.amazonaws.com/wooting-update/wootility-linux-latest/${_appimage}"
+source=("https://s3.eu-west-2.amazonaws.com/wooting-update/wootility-lekker-linux-latest/${_appimage}"
'70-wooting.rules')
-noextract=("${_appimage}")
-sha512sums=('27db389e5c31624c163dd6c7b4fb8624758cd2fbf0e10116d96511dde03aeb88a8e22423ffb584e3d042aa92e13ec703a15243daf469604ac7fb56dfc8465173'
- '3a569cb1292efc31e22fd6c425fff14ac98d7f280849b3d81cdd72523a3388e6623bcd026571f726656fb339f9b90527efd8829d82de1d0b1ac778921dd72633')
+b2sums=('6154ed86c7d655955baf976aaec307c1a4ebb0466a8c377e2d1325e88f4f11362d423cc9666c117d96e387c5458fd1ac073687a06199437f0414533088648e9c'
+ '80b4a516f8aafb6eada36cdde59295f2358b22e6cc28b1a21b0b5f22a59bcfabc63bba956d23544faca5fd76a1c4b4c1ff98ada41e7c9ad015d48c7c436dbac1')
prepare() {
- 7z x "${_appimage}" 'wootility.desktop' 'usr/share/icons' > /dev/null
+ # Copying AppImage in case $SRCDEST is mounted with noexec
+ cp ${_appimage} ${_appimage}.copy
+ chmod +x ${_appimage}.copy
+ ./${_appimage}.copy --appimage-extract ${_pkgname}-lekker.desktop
+ ./${_appimage}.copy --appimage-extract ${_pkgname}-lekker.png
+ ./${_appimage}.copy --appimage-extract usr/share/icons
+ rm ${_appimage}.copy
+ find squashfs-root/ \! -type d -exec rename ${_pkgname}-lekker ${_pkgname} \{\} \;
+ find squashfs-root/ -type l -exec rename --symlink ${_pkgname}-lekker ${_pkgname} \{\} \;
}
build() {
- sed -i -E "s|Exec=AppRun|Exec=${_pkgname}|" wootility.desktop
- # Fix permissions; .AppImage permissions are 700 for all directories
- chmod -R a-x+rX usr
+ sed -i -E "s|Exec=AppRun|Exec=${_pkgname}|" squashfs-root/${_pkgname}.desktop
+ sed -i -E "s|Name=.*$|Name=Wootility|" squashfs-root/${_pkgname}.desktop
+ sed -i -E "s|^Icon=.*$|Icon=${_pkgname}|" squashfs-root/${_pkgname}.desktop
}
package() {
- install -Dpm755 "${_appimage}" "${pkgdir}/opt/${_pkgname}/${_appimage}"
- install -d "${pkgdir}/usr/bin"
- ln -s "../../opt/${_pkgname}/${_appimage}" "${pkgdir}/usr/bin/${_pkgname}"
- install -Dpm644 'wootility.desktop' "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
- install -d "${pkgdir}/usr/share/icons"
- cp -a usr/share/icons/hicolor "${pkgdir}/usr/share/icons/hicolor"
- install -Dpm644 '70-wooting.rules' "${pkgdir}/usr/lib/udev/rules.d/70-wooting.rules"
+ install -Dpm755 "${_appimage}" "${pkgdir}/opt/${_pkgname}/${_appimage}"
+ install -d "${pkgdir}/usr/bin"
+ ln -s "../../opt/${_pkgname}/${_appimage}" "${pkgdir}/usr/bin/${_pkgname}"
+
+ # Install desktop entry and icon
+ install -Dpm644 "squashfs-root/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -Dpm644 "squashfs-root/${_pkgname}.png" "${pkgdir}/usr/share/icons/hicolor/512x512/apps/${_pkgname}.png"
+
+ # Install udev rules
+ install -Dpm644 "70-wooting.rules" "${pkgdir}/usr/lib/udev/rules.d/70-${_pkgname}.rules"
}
diff --git a/wootility-appimage.install b/wootility-appimage.install
index 176cdfd00da6..baffe52bc48a 100644
--- a/wootility-appimage.install
+++ b/wootility-appimage.install
@@ -1,7 +1,7 @@
post_install() {
- echo 'NOTE: To turn off the “Would you like to integrate ….AppImage with your system?”'
- echo 'NOTE: notifications on every launch of Wootility, see:'
- echo 'NOTE: https://github.com/AppImage/AppImageSpec/blob/master/draft.md#desktop-integration'
+ echo 'To turn off the “Would you like to integrate ….AppImage with your system?”'
+ echo 'notifications on every launch of Wootility, see:'
+ echo 'https://github.com/AppImage/AppImageSpec/blob/master/draft.md#desktop-integration'
}
post_upgrade() {