summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD17
2 files changed, 4 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68e92e178932..c16adb4ef5c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = worker
pkgdesc = A file manager for the X Window System
pkgver = 4.7.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.boomerangsworld.de/worker
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 259cf794eac1..88cf29791e13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Aaron Fischer <mail@aaron-fischer.net>
# Contributor: J. W. Birdsong <jwbirdsong AT gmail DOT com>
# Contributor: Kevin Piche <kevin@archlinux.org>
+# Contributor: Frank Carlyle McLaughlin <frank@frankspace.com>
pkgname=worker
pkgver=4.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="A file manager for the X Window System"
arch=('i686' 'x86_64')
license=('GPL')
@@ -21,19 +22,7 @@ validpgpkeys=('F9299EE90A729029E71AF26B667132D0FBC52B37') # Ralf Hoffmann
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
-
- # We need to disable the optimizations because of a bug in gcc
- # (see https://gcc.gnu.org/bugzilla/show_bug.cgi?id=63140 for details)
- # Ralf added a gcc constraint check to avoid compiling bad optimized code.
- # Because we run a recent version of gcc, we disable the check, and
- # disable also the compiler optimizations completely. Because the code
- # uses some C++11 features, we need to set this explicitly.
- #
- # To bypass the pthread bug, the LDFLAGS is set here explicit until
- # the bug is solved. See here for more detail and progress:
- # https://sourceforge.net/p/workerfm/mailman/message/34136485/
- CPPFLAGS="-O0 -std=gnu++14" LDFLAGS=-pthread ./configure --enable-xft --prefix=/usr --disable-cxx-check
-
+ ./configure --enable-xft --prefix=/usr
make
}