summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD44
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7c1a932503b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = wpgtk-git
+ pkgdesc = A gui wallpaper chooser that changes your Openbox theme, GTK theme and Tint2 theme
+ pkgver = r96.ba82065
+ pkgrel = 1
+ url = https://github.com/deviantfero/wpgtk
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = python
+ depends = python2
+ depends = python2-pillow
+ depends = feh
+ depends = python-gobject
+ depends = gtk3
+ depends = libxslt
+ provides = wpgtk
+ conflicts = wpgtk
+ source = git://github.com/deviantfero/wpgtk#branch=master
+ sha512sums = SKIP
+
+pkgname = wpgtk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b43c6ae4ce2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Fernando Vasquez <fmorataya.04@gmail.com>
+
+_gitname=wpgtk
+pkgname="${_gitname}-git"
+_gitbranch=master
+_gitauthor=deviantfero # djmelik
+pkgver=r96.ba82065
+pkgrel=1
+pkgdesc="A gui wallpaper chooser that changes your Openbox theme, GTK theme and Tint2 theme"
+url="https://github.com/${_gitauthor}/${_gitname}"
+license=('BSD')
+source=("git://github.com/${_gitauthor}/${_gitname}#branch=${_gitbranch}")
+sha512sums=('SKIP')
+arch=('any')
+depends=('python' 'python2' 'python2-pillow' 'feh' 'python-gobject' 'gtk3' 'libxslt')
+makedepends=('git')
+optdepends=()
+conflicts=("${_gitname}")
+provides=("${_gitname}")
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ (
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ echo "#!/bin/bash" > ./wpg
+ echo "/usr/bin/wpgtk/src/wpg.py" >> ./wpg
+ mkdir -p ${pkgdir}/usr/bin/wpgtk/py
+ mkdir -p ${pkgdir}/usr/bin/wpgtk/src
+ install -D -m755 ./py/* ${pkgdir}/usr/bin/wpgtk/py
+ install -D -m755 ./src/* ${pkgdir}/usr/bin/wpgtk/src
+ install -D -m775 ./wp ${pkgdir}/usr/bin/wp
+ install -D -m775 ./wpg ${pkgdir}/usr/bin/wpg
+ install -D -m755 ./functions ${pkgdir}/usr/bin/wpgtk/functions
+ bash ./installaur.sh
+}
+
+# vim:set et sw=2 sts=2 tw=80: