summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO46
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD85
-rw-r--r--wps-office-cn.install34
4 files changed, 172 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f97f4cf59b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+pkgbase = wps-office-cn
+ pkgdesc = Kingsoft Office (WPS Office) cn version - an office productivity suite
+ pkgver = 11.1.0.9080
+ pkgrel = 1
+ url = https://linux.wps.cn
+ arch = x86_64
+ license = custom
+ options = !emptydirs
+ source = https://wdl1.cache.wps.cn/wps/download/ep/Linux2019/9080/wps-office_11.1.0.9080_amd64.deb
+ sha1sums = 7daa9c0fdbf244daf92f057e93e71bd6cf46005d
+
+pkgname = wps-office-cn
+ install = wps-office-cn.install
+ depends = fontconfig
+ depends = xorg-mkfontdir
+ depends = libxrender
+ depends = gtk2
+ depends = desktop-file-utils
+ depends = shared-mime-info
+ depends = xdg-utils
+ depends = glu
+ depends = openssl-1.0
+ depends = sdl2
+ depends = libpulse
+ depends = hicolor-icon-theme
+ depends = libxss
+ depends = sqlite
+ depends = libtool
+ optdepends = cups: for printing support
+ optdepends = libjpeg-turbo: JPEG image codec support
+ optdepends = pango: for complex (right-to-left) text support
+ optdepends = curl: An URL retrieval utility and library
+ optdepends = ttf-wps-fonts: Symbol fonts required by wps-office
+ optdepends = ttf-ms-fonts: Microsft Fonts recommended for wps-office
+ optdepends = wps-office-fonts: FZ TTF fonts provided by wps community
+ optdepends = wps-office-mime-cn: Use mime files provided by Kingsoft
+ provides = wps-office
+ conflicts = kingsoft-office
+ conflicts = wps-office
+
+pkgname = wps-office-mime-cn
+ pkgdesc = Mime files provided by Kingsoft Office (WPS Office) cn version
+ depends = shared-mime-info
+ provides = wps-office-mime
+ conflicts = wps-office-mime
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1561816e0ad4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+src
+pkg
+*.src.tar.gz
+*.part
+*.pkg.tar.*
+*.deb
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65404c2b343f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,85 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Ouyang Jun <ouyangjun1999@gmail.com>
+# Contributor: Jove Yu <yushijun110 [at] gmail.com>
+# Contributor: Ariel AxionL <axionl at aosc dot io>
+
+pkgbase=wps-office-cn
+pkgname=('wps-office-cn' 'wps-office-mime-cn')
+pkgver=11.1.0.9080
+pkgrel=1
+pkgdesc="Kingsoft Office (WPS Office) cn version - an office productivity suite"
+arch=('x86_64')
+license=('custom')
+url="https://linux.wps.cn"
+options=('!emptydirs')
+source=("https://wdl1.cache.wps.cn/wps/download/ep/Linux2019/${pkgver##*.}/wps-office_${pkgver}_amd64.deb")
+sha1sums=('7daa9c0fdbf244daf92f057e93e71bd6cf46005d')
+
+prepare() {
+ bsdtar -xpf data.tar.xz
+
+ cd "${srcdir}/usr/bin"
+ sed -i 's|/opt/kingsoft/wps-office|/usr/lib|' *
+
+ cd "${srcdir}/usr/share/icons/hicolor"
+ for _file in ./*; do
+ if [ -e ${_file}/mimetypes/wps-office2019-etmain.png ]; then
+ mkdir -p ${_file}/apps
+ cp -p ${_file}/mimetypes/wps-office2019* ${_file}/apps
+ fi
+ done
+}
+
+package_wps-office-cn() {
+ depends=('fontconfig' 'xorg-mkfontdir' 'libxrender' 'gtk2' 'desktop-file-utils' 'shared-mime-info' 'xdg-utils' 'glu' 'openssl-1.0' 'sdl2' 'libpulse' 'hicolor-icon-theme' 'libxss' 'sqlite' 'libtool')
+ optdepends=('cups: for printing support'
+ 'libjpeg-turbo: JPEG image codec support'
+ 'pango: for complex (right-to-left) text support'
+ 'curl: An URL retrieval utility and library'
+ 'ttf-wps-fonts: Symbol fonts required by wps-office'
+ 'ttf-ms-fonts: Microsft Fonts recommended for wps-office'
+ 'wps-office-fonts: FZ TTF fonts provided by wps community'
+ 'wps-office-mime-cn: Use mime files provided by Kingsoft')
+ install=${pkgname}.install
+ conflicts=('kingsoft-office' 'wps-office')
+ provides=('wps-office')
+ cd "${srcdir}/opt/kingsoft/wps-office/"
+
+ install -d "${pkgdir}/usr/lib"
+ cp -r office6 "${pkgdir}/usr/lib"
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" office6/mui/default/*.txt
+
+ install -d "${pkgdir}/usr/bin"
+ cd "${srcdir}/usr/bin"
+ install -m755 * "${pkgdir}/usr/bin"
+
+ cd "${srcdir}/usr/share"
+
+ install -d "${pkgdir}/usr/share/applications"
+ cp -r applications/* "${pkgdir}/usr/share/applications"
+
+ install -d "${pkgdir}/usr/share/desktop-directories"
+ cp -r desktop-directories/* "${pkgdir}/usr/share/desktop-directories"
+
+ install -d "${pkgdir}/usr/share/icons"
+ cp -r icons/* "${pkgdir}/usr/share/icons"
+
+ install -Dm644 -t "${pkgdir}/usr/share/fonts/wps-office" fonts/wps-office/*
+
+ install -Dm644 -t "${pkgdir}/etc/xdg/menus/applications-merged" "${srcdir}/etc/xdg/menus/applications-merged/wps-office.menu"
+}
+
+package_wps-office-mime-cn() {
+ pkgdesc="Mime files provided by Kingsoft Office (WPS Office) cn version"
+ depends=('shared-mime-info')
+ conflicts=('wps-office-mime')
+ provides=('wps-office-mime')
+ cd "${srcdir}/usr/share"
+
+ install -d "${pkgdir}/usr/share/mime"
+ cp -r mime/* "${pkgdir}/usr/share/mime"
+
+ cd "${srcdir}/opt/kingsoft/wps-office/"
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" office6/mui/default/*.txt
+}
diff --git a/wps-office-cn.install b/wps-office-cn.install
new file mode 100644
index 000000000000..f73443db2fbe
--- /dev/null
+++ b/wps-office-cn.install
@@ -0,0 +1,34 @@
+#!/bin/bash
+
+function whisperer(){
+ echo "-----------------------------------------------------------------------"
+ echo "For more info and more troubleshooting visit:"
+ echo "Chinese: http://linux.wps.cn/"
+ echo "English: http://wps-community.org/"
+ echo "-----------------------------------------------------------------------"
+ echo ""
+ echo "-----------------------------------------------------------------------"
+ echo "Kingsoft Office (WPS Office), is an office productivity suite."
+ echo ""
+ echo "Kingsoft Office (also named WPS Office) including Writer, Presentation"
+ echo "and Spreadsheets, is a powerful office suite, which is able to process"
+ echo "word file, produce wonderful slides, and analyze data as well. It is"
+ echo "deeply compatible with all of the latest Microsoft Office file formats. "
+ echo "It can easily open and read the documents created with Microsoft Office."
+ echo ""
+ echo "This is the Linux version, and it's now an ALPHA package."
+ echo "-----------------------------------------------------------------------"
+ echo ""
+ echo "-----------------------------------------------------------------------"
+ echo ""
+ echo "ATTENTION: When you shut down wps, the wpsoffice process may still exist."
+ echo "You can do 'sudo chmod -x /usr/lib/office6/wpsoffice' to fix it. But"
+ echo "this might bring you problem with signing in."
+ echo ""
+ echo "-----------------------------------------------------------------------"
+}
+
+post_install()
+{
+ whisperer
+}