summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--wsjtx.patch9
3 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78565ceaee21..d8fdacb82dce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wsjtx-git
pkgdesc = Software for Amateur Radio Weak-Signal Communication (JT9 and JT65)
pkgver = r4218.f962caac
- pkgrel = 1
+ pkgrel = 2
url = http://physics.princeton.edu/pulsar/k1jt/wsjtx.html
arch = i686
arch = x86_64
@@ -22,7 +22,7 @@ pkgbase = wsjtx-git
source = git+https://git.code.sf.net/p/wsjt/wsjtx/
source = wsjtx.patch
md5sums = SKIP
- md5sums = c5a2c0b91c2709e070d7ebcb75621354
+ md5sums = db95112aa92f4f974df85c4afc50fedc
pkgname = wsjtx-git
diff --git a/PKGBUILD b/PKGBUILD
index e4946a71bb9e..5fb9afb63426 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=wsjtx-git
pkgver=r4218.f962caac
-pkgrel=1
+pkgrel=2
pkgdesc='Software for Amateur Radio Weak-Signal Communication (JT9 and JT65)'
arch=('i686' 'x86_64')
url='http://physics.princeton.edu/pulsar/k1jt/wsjtx.html'
@@ -15,7 +15,7 @@ conflicts=('wsjtx')
source=('git+https://git.code.sf.net/p/wsjt/wsjtx/'
'wsjtx.patch')
md5sums=('SKIP'
- 'c5a2c0b91c2709e070d7ebcb75621354')
+ 'db95112aa92f4f974df85c4afc50fedc')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -26,7 +26,6 @@ prepare() {
cp wsjtx.patch "$srcdir/${pkgname%-git}"
cd "$srcdir/${pkgname%-git}"
patch -i wsjtx.patch
- sed -ri 's/^find_package \(hamlib 3 REQUIRED\)/set \(hamlib_LIBRARIES hamlib\)/' CMakeLists.txt
}
build() {
diff --git a/wsjtx.patch b/wsjtx.patch
index 9b8e043ab3dd..a03d72db2d54 100644
--- a/wsjtx.patch
+++ b/wsjtx.patch
@@ -1,6 +1,15 @@
diff -ur /CMakeLists.txt /CMakeLists.txt
--- /CMakeLists.txt 2018-05-31 02:29:47.000000000 +0200
+++ /CMakeLists.txt 2018-06-03 09:34:15.109877528 +0200
+@@ -861,7 +861,7 @@
+ # libhamlib setup
+ #
+ set (hamlib_STATIC 1)
+-find_package (hamlib 3 REQUIRED)
++set (hamlib_LIBRARIES hamlib)
+ find_program (RIGCTL_EXE rigctl)
+ find_program (RIGCTLD_EXE rigctld)
+
@@ -1343,7 +1343,8 @@
)
endif ()