summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD7
-rw-r--r--wsjtx.patch43
2 files changed, 32 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ef0c108b9b6..d1691b980c39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,10 @@
# Contributor: Thomas Gatzweiler <thomas.gatzweiler@gmail.com> wsjtx-svn maintainer
pkgname=wsjtx-git
-pkgver=r4933.784f75ea
+pkgver=r5020.7ddcb798
pkgrel=1
pkgdesc='Software for Amateur Radio Weak-Signal Communication (JT9 and JT65)'
+_wsjtx_tag=master
arch=('i686' 'x86_64')
url='http://physics.princeton.edu/pulsar/k1jt/wsjtx.html'
license=('GPL-3')
@@ -12,10 +13,10 @@ depends=('qt5-base' 'qt5-multimedia' 'qt5-serialport' 'libusb' 'libusb-compat' '
makedepends=('cmake' 'git' 'asciidoctor' 'asciidoc')
provides=('wsjtx')
conflicts=('wsjtx')
-source=('git+https://git.code.sf.net/p/wsjt/wsjtx/'
+source=('git+https://git.code.sf.net/p/wsjt/wsjtx/#tag=$_wsjtx_tag'
'wsjtx.patch')
md5sums=('SKIP'
- 'db95112aa92f4f974df85c4afc50fedc')
+ '7f736f90de84106b1c899d1be464f530')
pkgver() {
cd "$srcdir/${pkgname%-git}"
diff --git a/wsjtx.patch b/wsjtx.patch
index a03d72db2d54..66d8726d3d26 100644
--- a/wsjtx.patch
+++ b/wsjtx.patch
@@ -1,32 +1,45 @@
-diff -ur /CMakeLists.txt /CMakeLists.txt
---- /CMakeLists.txt 2018-05-31 02:29:47.000000000 +0200
-+++ /CMakeLists.txt 2018-06-03 09:34:15.109877528 +0200
-@@ -861,7 +861,7 @@
+--- CMakeLists.txt 2019-05-27 12:04:08.383328015 -0500
++++ CMakeLists.txt 2019-05-27 12:03:24.470182804 -0500
+@@ -845,7 +845,7 @@
# libhamlib setup
#
set (hamlib_STATIC 1)
--find_package (hamlib 3 REQUIRED)
-+set (hamlib_LIBRARIES hamlib)
+-set (hamlib_LIBRARIES hamlib)
++find_package (hamlib 3 REQUIRED)
find_program (RIGCTL_EXE rigctl)
find_program (RIGCTLD_EXE rigctld)
-
-@@ -1343,7 +1343,8 @@
+ find_program (RIGCTLCOM_EXE rigctlcom)
+@@ -1305,8 +1305,7 @@
)
endif ()
endif ()
--qt5_use_modules (wsjtx SerialPort) # not sure why the interface link library syntax above doesn't work
-+find_package (Qt5SerialPort)
-+target_link_libraries (wsjtx Qt5::SerialPort)
+-find_package (Qt5SerialPort)
+-target_link_libraries (wsjtx Qt5::SerialPort)
++qt5_use_modules (wsjtx SerialPort) # not sure why the interface link library syntax above doesn't work
# make a library for WSJT-X UDP servers
# add_library (wsjtx_udp SHARED ${UDP_library_CXXSRCS})
-@@ -1364,7 +1365,8 @@
+@@ -1327,8 +1326,7 @@
)
target_compile_definitions (wsjtx_udp-static PUBLIC UDP_STATIC_DEFINE)
#qt5_use_modules (wsjtx_udp Network)
--qt5_use_modules (wsjtx_udp-static Network Gui)
-+target_link_libraries (wsjtx_udp-static Qt5::Network Qt5::Gui)
-+
+-target_link_libraries (wsjtx_udp-static Qt5::Network Qt5::Gui)
+-
++qt5_use_modules (wsjtx_udp-static Network Gui)
generate_export_header (wsjtx_udp-static BASE_NAME udp)
add_executable (udp_daemon UDPExamples/UDPDaemon.cpp UDPExamples/udp_daemon.rc ${WSJTX_ICON_FILE})
+@@ -1420,6 +1418,13 @@
+ RENAME rigctld-wsjtx${CMAKE_EXECUTABLE_SUFFIX}
+ )
+
++install (PROGRAMS
++ ${RIGCTLCOM_EXE}
++ DESTINATION ${CMAKE_INSTALL_BINDIR}
++ #COMPONENT runtime
++ RENAME rigctlcom-wsjtx${CMAKE_EXECUTABLE_SUFFIX}
++ )
++
+ install (FILES
+ README
+ COPYING