summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD7
-rw-r--r--wsjtx.patch40
2 files changed, 24 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1691b980c39..0ec604346758 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,6 +5,7 @@ pkgname=wsjtx-git
pkgver=r5020.7ddcb798
pkgrel=1
pkgdesc='Software for Amateur Radio Weak-Signal Communication (JT9 and JT65)'
+# change _wsjtx_tag to other versions such as wsjtx-2.1.0-rc5
_wsjtx_tag=master
arch=('i686' 'x86_64')
url='http://physics.princeton.edu/pulsar/k1jt/wsjtx.html'
@@ -13,10 +14,10 @@ depends=('qt5-base' 'qt5-multimedia' 'qt5-serialport' 'libusb' 'libusb-compat' '
makedepends=('cmake' 'git' 'asciidoctor' 'asciidoc')
provides=('wsjtx')
conflicts=('wsjtx')
-source=('git+https://git.code.sf.net/p/wsjt/wsjtx/#tag=$_wsjtx_tag'
- 'wsjtx.patch')
+source=("git+https://git.code.sf.net/p/wsjt/wsjtx/#tag=$_wsjtx_tag"
+ "wsjtx.patch")
md5sums=('SKIP'
- '7f736f90de84106b1c899d1be464f530')
+ 'c344fe634d4a9d1b15300970f0fa019b')
pkgver() {
cd "$srcdir/${pkgname%-git}"
diff --git a/wsjtx.patch b/wsjtx.patch
index 66d8726d3d26..c11041ef1d22 100644
--- a/wsjtx.patch
+++ b/wsjtx.patch
@@ -1,45 +1,45 @@
---- CMakeLists.txt 2019-05-27 12:04:08.383328015 -0500
-+++ CMakeLists.txt 2019-05-27 12:03:24.470182804 -0500
+--- CMakeLists.txt 2019-05-27 12:15:30.212133672 -0500
++++ CMakeLists.txt 2019-05-27 12:16:01.995437956 -0500
@@ -845,7 +845,7 @@
# libhamlib setup
#
set (hamlib_STATIC 1)
--set (hamlib_LIBRARIES hamlib)
-+find_package (hamlib 3 REQUIRED)
+-find_package (hamlib 3 REQUIRED)
++set (hamlib_LIBRARIES hamlib)
find_program (RIGCTL_EXE rigctl)
find_program (RIGCTLD_EXE rigctld)
find_program (RIGCTLCOM_EXE rigctlcom)
-@@ -1305,8 +1305,7 @@
+@@ -1305,7 +1305,8 @@
)
endif ()
endif ()
--find_package (Qt5SerialPort)
--target_link_libraries (wsjtx Qt5::SerialPort)
-+qt5_use_modules (wsjtx SerialPort) # not sure why the interface link library syntax above doesn't work
+-qt5_use_modules (wsjtx SerialPort) # not sure why the interface link library syntax above doesn't work
++find_package (Qt5SerialPort)
++target_link_libraries (wsjtx Qt5::SerialPort)
# make a library for WSJT-X UDP servers
# add_library (wsjtx_udp SHARED ${UDP_library_CXXSRCS})
-@@ -1327,8 +1326,7 @@
+@@ -1326,7 +1327,8 @@
)
target_compile_definitions (wsjtx_udp-static PUBLIC UDP_STATIC_DEFINE)
#qt5_use_modules (wsjtx_udp Network)
--target_link_libraries (wsjtx_udp-static Qt5::Network Qt5::Gui)
--
-+qt5_use_modules (wsjtx_udp-static Network Gui)
+-qt5_use_modules (wsjtx_udp-static Network Gui)
++target_link_libraries (wsjtx_udp-static Qt5::Network Qt5::Gui)
++
generate_export_header (wsjtx_udp-static BASE_NAME udp)
add_executable (udp_daemon UDPExamples/UDPDaemon.cpp UDPExamples/udp_daemon.rc ${WSJTX_ICON_FILE})
-@@ -1420,6 +1418,13 @@
+@@ -1418,13 +1420,6 @@
RENAME rigctld-wsjtx${CMAKE_EXECUTABLE_SUFFIX}
)
-+install (PROGRAMS
-+ ${RIGCTLCOM_EXE}
-+ DESTINATION ${CMAKE_INSTALL_BINDIR}
-+ #COMPONENT runtime
-+ RENAME rigctlcom-wsjtx${CMAKE_EXECUTABLE_SUFFIX}
-+ )
-+
+-install (PROGRAMS
+- ${RIGCTLCOM_EXE}
+- DESTINATION ${CMAKE_INSTALL_BINDIR}
+- #COMPONENT runtime
+- RENAME rigctlcom-wsjtx${CMAKE_EXECUTABLE_SUFFIX}
+- )
+-
install (FILES
README
COPYING