summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
-rw-r--r--wsjtx.patch27
3 files changed, 7 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b4c112e3d6c..8288c9617fee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wsjtx-git
pkgdesc = Software for Amateur Radio Weak-Signal Communication (JT9 and JT65)
- pkgver = r6921.4c05f80a2
+ pkgver = r8835.68a3d410d
pkgrel = 1
url = http://physics.princeton.edu/pulsar/k1jt/wsjtx.html
arch = i686
@@ -18,13 +18,10 @@ pkgbase = wsjtx-git
depends = libusb
depends = libusb-compat
depends = fftw
- depends = hamlib
+ depends = hamlib-git
provides = wsjtx
conflicts = wsjtx
source = git+https://git.code.sf.net/p/wsjt/wsjtx/#tag=master
- source = wsjtx.patch
md5sums = SKIP
- md5sums = 4a6220d2a93011fff9057046a15a43c0
pkgname = wsjtx-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 68240a0b0c5d..475799d0c723 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,20 @@
# Contributor: Thomas Gatzweiler <thomas.gatzweiler@gmail.com> wsjtx-svn maintainer
pkgname=wsjtx-git
-pkgver=r6921.4c05f80a2
+pkgver=r8835.68a3d410d
pkgrel=1
pkgdesc='Software for Amateur Radio Weak-Signal Communication (JT9 and JT65)'
-# change _wsjtx_tag to other versions such as wsjtx-2.1.0-rc5
+# change _wsjtx_tag to other versions such as wsjtx-2.5.0-rc1
_wsjtx_tag=master
arch=('i686' 'x86_64')
url='http://physics.princeton.edu/pulsar/k1jt/wsjtx.html'
license=('GPL-3')
-depends=('qt5-base' 'qt5-multimedia' 'qt5-serialport' 'libusb' 'libusb-compat' 'fftw' 'hamlib')
+depends=('qt5-base' 'qt5-multimedia' 'qt5-serialport' 'libusb' 'libusb-compat' 'fftw' 'hamlib-git')
makedepends=('cmake' 'git' 'asciidoctor' 'asciidoc' 'qt5-tools' 'gcc-fortran')
provides=('wsjtx')
conflicts=('wsjtx')
-source=("git+https://git.code.sf.net/p/wsjt/wsjtx/#tag=$_wsjtx_tag"
- "wsjtx.patch")
-md5sums=('SKIP'
- '4a6220d2a93011fff9057046a15a43c0')
+source=("git+https://git.code.sf.net/p/wsjt/wsjtx/#tag=$_wsjtx_tag")
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -25,9 +23,7 @@ pkgver() {
}
prepare() {
- cp wsjtx.patch "$srcdir/${pkgname%-git}"
cd "$srcdir/${pkgname%-git}"
- patch -i wsjtx.patch
}
build() {
diff --git a/wsjtx.patch b/wsjtx.patch
deleted file mode 100644
index 3298406ccf3a..000000000000
--- a/wsjtx.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 72c38fa13..8a876da64 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -854,7 +854,7 @@ find_package (FFTW3 COMPONENTS single threads REQUIRED)
- # libhamlib setup
- #
- set (hamlib_STATIC 1)
--find_package (hamlib 3 REQUIRED)
-+set (hamlib_LIBRARIES hamlib)
- find_program (RIGCTL_EXE rigctl)
- find_program (RIGCTLD_EXE rigctld)
- find_program (RIGCTLCOM_EXE rigctlcom)
-@@ -1549,13 +1549,6 @@ install (PROGRAMS
- RENAME rigctld-wsjtx${CMAKE_EXECUTABLE_SUFFIX}
- )
-
--install (PROGRAMS
-- ${RIGCTLCOM_EXE}
-- DESTINATION ${CMAKE_INSTALL_BINDIR}
-- #COMPONENT runtime
-- RENAME rigctlcom-wsjtx${CMAKE_EXECUTABLE_SUFFIX}
-- )
--
- install (FILES
- README
- COPYING