summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--wsjtx.patch42
3 files changed, 3 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6014c7dd9190..2ce97f661930 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wsjtx-superbuild-git
pkgdesc = Software for Amateur Radio Weak-Signal Communication (JT9 and JT65) - Superbuild/git version, hamlib not required
pkgver = r35.491536f
- pkgrel = 4
+ pkgrel = 5
url = http://physics.princeton.edu/pulsar/k1jt/wsjtx.html
arch = i686
arch = x86_64
@@ -21,10 +21,8 @@ pkgbase = wsjtx-superbuild-git
provides = wsjtx
conflicts = wsjtx
source = git+https://git.code.sf.net/p/wsjt/wsjtx-superbuild/
- source = wsjtx.patch
source = repo.patch
md5sums = SKIP
- md5sums = f50bfe0cb3d7bf91ee9b6b6302b78d65
md5sums = d7446a4c8d44880b1c772493a7f170c6
pkgname = wsjtx-superbuild-git
diff --git a/PKGBUILD b/PKGBUILD
index cf6c03b65f7e..cbeb63c083fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=wsjtx-superbuild-git
pkgver=r35.491536f
-pkgrel=4
+pkgrel=5
pkgdesc='Software for Amateur Radio Weak-Signal Communication (JT9 and JT65) - Superbuild/git version, hamlib not required'
arch=('i686' 'x86_64')
url='http://physics.princeton.edu/pulsar/k1jt/wsjtx.html'
@@ -12,13 +12,11 @@ makedepends=('cmake' 'git' 'asciidoc' 'asciidoctor' 'qt5-tools' 'gcc-fortran')
provides=('wsjtx')
conflicts=('wsjtx')
source=('git+https://git.code.sf.net/p/wsjt/wsjtx-superbuild/'
- 'wsjtx.patch'
'repo.patch')
md5sums=('SKIP'
- 'f50bfe0cb3d7bf91ee9b6b6302b78d65'
'd7446a4c8d44880b1c772493a7f170c6')
#set branch to build with WSJTX_TAG variable, or a specific version eg. wsjtx-1.9.0
-_wsjtx_tag=wsjtx-2.1.2
+_wsjtx_tag=master
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -27,7 +25,6 @@ pkgver() {
build() {
patch -p1 -i repo.patch
- cp wsjtx.patch "$srcdir/${pkgname%-git}"
mkdir -p "$srcdir/${pkgname%-git}/build"
cd "$srcdir/${pkgname%-git}/build"
cmake -DWSJTX_TAG=$_wsjtx_tag -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
diff --git a/wsjtx.patch b/wsjtx.patch
deleted file mode 100644
index 41db48728059..000000000000
--- a/wsjtx.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff -ur /CMakeLists.txt /CMakeLists.txt
---- /CMakeLists.txt 2018-05-31 02:29:47.000000000 +0200
-+++ /CMakeLists.txt 2018-06-03 09:34:15.109877528 +0200
-@@ -1343,7 +1343,8 @@
- )
- endif ()
- endif ()
--qt5_use_modules (wsjtx SerialPort) # not sure why the interface link library syntax above doesn't work
-+find_package (Qt5SerialPort)
-+target_link_libraries (wsjtx Qt5::SerialPort)
-
- # make a library for WSJT-X UDP servers
- # add_library (wsjtx_udp SHARED ${UDP_library_CXXSRCS})
-@@ -1364,7 +1365,8 @@
- )
- target_compile_definitions (wsjtx_udp-static PUBLIC UDP_STATIC_DEFINE)
- #qt5_use_modules (wsjtx_udp Network)
--qt5_use_modules (wsjtx_udp-static Network Gui)
-+target_link_libraries (wsjtx_udp-static Qt5::Network Qt5::Gui)
-+
- generate_export_header (wsjtx_udp-static BASE_NAME udp)
-
- add_executable (udp_daemon UDPExamples/UDPDaemon.cpp UDPExamples/udp_daemon.rc ${WSJTX_ICON_FILE})
-
---- a/qt_helpers.hpp 2019-11-26 09:22:32.000000000 -0500
-+++ b/qt_helpers.hpp 2020-02-03 11:30:07.488214336 -0500
-@@ -83,6 +83,7 @@
- // std::hash<> specialization for QString based on the dbj2
- // algorithm <http://www.cse.yorku.ca/~oz/hash.html> because qHash()
- // is poor on 64-bit platforms due to being a 32-bit hash value
-+ #if QT_VERSION < QT_VERSION_CHECK(5, 14, 0)
- template<>
- struct hash<QString>
- {
-@@ -96,6 +97,7 @@
- return hash;
- }
- };
-+#endif
- }
-
- // Register some useful Qt types with QMetaType