summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5cecd5305512
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = wut-git
+ pkgdesc = A Wii U toolchain/SDK for creating RPX/RPL
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/decaf-emu/wut
+ arch = x86_64
+ license = GPLv2
+ makedepends = cmake
+ makedepends = zlib
+ makedepends = git
+ depends = devkitppc
+ provides = wut
+ options = !strip
+ options = !buildflags
+ source = git+https://github.com/decaf-emu/wut
+ md5sums = SKIP
+
+pkgname = wut-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9fd1b38cfa1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Mikaela RJ Szekely <qyriad@gmail.com>
+pkgname=wut-git
+_pkgname=wut
+pkgver=0.1
+pkgrel=1
+pkgdesc="A Wii U toolchain/SDK for creating RPX/RPL"
+arch=("x86_64")
+url="https://github.com/decaf-emu/wut"
+license=("GPLv2")
+depends=("devkitppc")
+makedepends=("cmake" "zlib" "git")
+provides=("wut")
+source=("git+https://github.com/decaf-emu/wut")
+md5sums=("SKIP")
+options=("!strip" "!buildflags")
+
+prepare()
+{
+ cd "$srcdir"
+ cd "$_pkgname"
+ git submodule update --init --recursive
+}
+
+build()
+{
+ export DEVKITPRO=/opt/devkitpro
+ export DEVKITPPC=/opt/devkitpro/devkitPPC
+ cd "$srcdir/$_pkgname"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr ../
+ make
+}
+
+package()
+{
+ cd "$srcdir/$_pkgname/build"
+ make install
+}