summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd4f8468fe58..fb3ee0de09e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wwise-audio-tools-git
pkgdesc = Tools for working with Wwise file types (only extraction at the moment)
- pkgver = 0.5.0
+ pkgver = 0.5.0.r3.g16400e4
pkgrel = 1
url = https://github.com/WolvenKit/wwise-audio-tools
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 1f05ef85e953..3abfe7f65321 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Abheek Dhawan <abheekd at protonmail dot com>
pkgname="wwise-audio-tools-git"
-pkgver="0.5.0"
+pkgver=0.5.0.r3.g16400e4
pkgrel=1
pkgdesc="Tools for working with Wwise file types (only extraction at the moment)"
arch=("x86_64")
@@ -11,6 +11,11 @@ makedepends=("cmake" "ninja" "git")
source=("git+https://github.com/WolvenKit/wwise-audio-tools")
sha512sums=("SKIP")
+pkgver() {
+ cd ${srcdir}/wwise-audio-tools
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
prepare() {
cd "${srcdir}/wwise-audio-tools"
git submodule update --init