summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD52
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f3435182315
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = wwwidgets
+ pkgdesc = professional set of useful widgets for qt4 and qt5
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.wysota.eu.org/wwwidgets/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt5-base
+ depends = qt5-tools
+ source = http://www.wysota.eu.org/wwwidgets/wwWidgets-1.0-qt5.tar.gz
+ sha256sums = 81d797e7493a23ee50d695180026cb2a14b0519c834982fee00d3fa63733cd7f
+
+pkgname = wwwidgets
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9dd92a3b8e4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Matt Coffin <mcoffin13@gmail.com>
+pkgname=wwwidgets
+pkgver=1.0
+pkgrel=1
+epoch=
+pkgdesc="professional set of useful widgets for qt4 and qt5"
+arch=('i686' 'x86_64')
+url="http://www.wysota.eu.org/wwwidgets/"
+license=('GPL')
+groups=()
+depends=('qt5-base' 'qt5-tools')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("http://www.wysota.eu.org/wwwidgets/wwWidgets-$pkgver-qt5.tar.gz")
+noextract=()
+sha256sums=('81d797e7493a23ee50d695180026cb2a14b0519c834982fee00d3fa63733cd7f')
+validpgpkeys=()
+
+prepare() {
+ cd "wwWidgets"
+}
+
+build() {
+ cd "wwWidgets"
+ qmake
+ make sub-widgets
+}
+
+check() {
+ cd "wwWidgets"
+}
+
+package() {
+ cd "wwWidgets"
+ mkdir -p "$pkgdir/usr/lib"
+ install -m 0644 -t "$pkgdir/usr/lib" "widgets/libwwwidgets4.so.$pkgver"
+ ln -s "/usr/lib/libwwwidgets4.so.$pkgver" "$pkgdir/usr/lib/libwwwidgets4.so.1"
+ ln -s "/usr/lib/libwwwidgets4.so.$pkgver" "$pkgdir/usr/lib/libwwwidgets4.so"
+}