summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
-rw-r--r--configure.patch11
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ffe7c808255
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = wxedid
+ pkgdesc = wxWidgets-based EDID (Extended Display Identification Data) editor
+ pkgver = 0.0.16
+ pkgrel = 1
+ url = https://sourceforge.net/projects/wxedid/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = wxgtk2
+ source = https://downloads.sourceforge.net/wxedid/wxedid-0.0.16.tar.gz
+ source = configure.patch
+ md5sums = 0b1a6c49274e0fc3f2398648d99d6954
+ md5sums = 519658fdadcbe8c0b66c6d47c1c8715f
+
+pkgname = wxedid
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..deb7306ee3c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jonathan Liu <net147@gmail.com>
+pkgname=wxedid
+pkgver=0.0.16
+pkgrel=1
+pkgdesc="wxWidgets-based EDID (Extended Display Identification Data) editor"
+arch=('i686' 'x86_64')
+url="https://sourceforge.net/projects/wxedid/"
+license=('GPL3')
+depends=('wxgtk2')
+source=("https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+ 'configure.patch')
+md5sums=('0b1a6c49274e0fc3f2398648d99d6954'
+ '519658fdadcbe8c0b66c6d47c1c8715f')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -Np1 -i "$srcdir/configure.patch"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ autoreconf -f -i
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/configure.patch b/configure.patch
new file mode 100644
index 000000000000..4a7e4433aefe
--- /dev/null
+++ b/configure.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac 2018-12-01 23:43:13.000000000 +1100
++++ b/configure.ac 2018-12-11 10:50:59.989268036 +1100
+@@ -24,8 +24,6 @@
+ AS_VAR_SET([ac_lang_cflags], [$CFLAGS])
+
+ dnl AC_ARG_SWITCH_DEBUG([DEFINE-DBG-VAR], [DBG-CFLAGS], [DBG-LDFLAGS], [RELEASE-CFLAGS], [RELEASE-LDLAGS])
+-AC_BUILD_SWITCH([-g -Wall -Wextra -fno-exceptions], [],
+- [-s -O2 -finline-functions-called-once -fno-exceptions -Wall -Wfatal-errors], [])
+
+ AC_SUBST([ac_lang_cflags])
+