summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--configure.patch6
3 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 626d68537029..36c0fd31664a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = wxedid
pkgdesc = wxWidgets-based EDID (Extended Display Identification Data) editor
- pkgver = 0.0.17
+ pkgver = 0.0.18
pkgrel = 1
url = https://sourceforge.net/projects/wxedid/
arch = i686
arch = x86_64
license = GPL3
depends = wxgtk2
- source = https://downloads.sourceforge.net/wxedid/wxedid-0.0.17.tar.gz
+ source = https://downloads.sourceforge.net/wxedid/wxedid-0.0.18.tar.gz
source = configure.patch
- md5sums = eb09f18621954eece112a8266d4f0f74
- md5sums = 519658fdadcbe8c0b66c6d47c1c8715f
+ md5sums = 4098b6355d6a0ed76d06c33bb9499b27
+ md5sums = 1443b5b6e81b32df7c4a5c036603c52f
pkgname = wxedid
diff --git a/PKGBUILD b/PKGBUILD
index 7acf86f77c22..30fc0f3f46ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jonathan Liu <net147@gmail.com>
pkgname=wxedid
-pkgver=0.0.17
+pkgver=0.0.18
pkgrel=1
pkgdesc="wxWidgets-based EDID (Extended Display Identification Data) editor"
arch=('i686' 'x86_64')
@@ -9,14 +9,15 @@ license=('GPL3')
depends=('wxgtk2')
source=("https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
'configure.patch')
-md5sums=('eb09f18621954eece112a8266d4f0f74'
- '519658fdadcbe8c0b66c6d47c1c8715f')
+md5sums=('4098b6355d6a0ed76d06c33bb9499b27'
+ '1443b5b6e81b32df7c4a5c036603c52f')
prepare() {
cd "$pkgname-$pkgver"
patch -Np1 -i "$srcdir/configure.patch"
}
+
build() {
cd "$pkgname-$pkgver"
autoreconf -f -i
@@ -31,7 +32,7 @@ check() {
package() {
cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir" install
}
# vim:set ts=2 sw=2 et:
diff --git a/configure.patch b/configure.patch
index 4a7e4433aefe..f29401ff3725 100644
--- a/configure.patch
+++ b/configure.patch
@@ -1,11 +1,11 @@
---- a/configure.ac 2018-12-01 23:43:13.000000000 +1100
-+++ b/configure.ac 2018-12-11 10:50:59.989268036 +1100
+--- a/configure.ac
++++ b/configure.ac
@@ -24,8 +24,6 @@
AS_VAR_SET([ac_lang_cflags], [$CFLAGS])
dnl AC_ARG_SWITCH_DEBUG([DEFINE-DBG-VAR], [DBG-CFLAGS], [DBG-LDFLAGS], [RELEASE-CFLAGS], [RELEASE-LDLAGS])
-AC_BUILD_SWITCH([-g -Wall -Wextra -fno-exceptions], [],
-- [-s -O2 -finline-functions-called-once -fno-exceptions -Wall -Wfatal-errors], [])
+- [-O1 -finline-functions-called-once -fno-exceptions -Wall -Wfatal-errors], [-s])
AC_SUBST([ac_lang_cflags])