summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD56
-rw-r--r--wxlauncher.desktop11
-rw-r--r--wxlauncher.install12
-rw-r--r--wxlauncher.pngbin0 -> 3334 bytes
-rw-r--r--wxlauncher_homedir.patch27
6 files changed, 129 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..023aea5ffe5c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = wxlauncher
+ pkgdesc = wxLauncher is a cross-platform launcher for the FreeSpace 2 Open engine
+ pkgver = 0.9.6
+ pkgrel = 1
+ url = http://www.hard-light.net/forums/index.php?topic=67950.0
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ depends = wxpython
+ depends = python2
+ depends = python2-markdown
+ depends = openal
+ optdepends = fs2_open
+ source = https://github.com/wxLauncher/wxlauncher/archive/revision-0.9.6.zip
+ source = wxlauncher.png
+ source = wxlauncher.desktop
+ sha256sums = a39051eff51462bbb5610758519cd7ba74723e73e5716a4913cee62ad39917a0
+ sha256sums = e3bf9cbe7c61378026331a21313fccd891b051e949448715625d1cfd3ae72576
+ sha256sums = 8de688171c12fdf273ece4f33177fd773395204c81cf212f8c4293f0ddd16582
+
+pkgname = wxlauncher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b11c4560037
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Michael Mansell <michael.mansell@gmail.com>
+# Contributor: Joe Davison <joedavison.davison@gmail.com>
+
+pkgname=wxlauncher
+_pkgtar=wxlauncher
+pkgver=0.9.6
+pkgrel=1
+
+source=("https://github.com/wxLauncher/wxlauncher/archive/revision-0.9.6.zip"
+ "wxlauncher.png"
+ "wxlauncher.desktop")
+sha256sums=('a39051eff51462bbb5610758519cd7ba74723e73e5716a4913cee62ad39917a0'
+ 'e3bf9cbe7c61378026331a21313fccd891b051e949448715625d1cfd3ae72576'
+ '8de688171c12fdf273ece4f33177fd773395204c81cf212f8c4293f0ddd16582')
+
+pkgdesc="wxLauncher is a cross-platform launcher for the FreeSpace 2 Open engine"
+url="http://www.hard-light.net/forums/index.php?topic=67950.0"
+arch=(i686 x86_64)
+license=(GPL2)
+# change below if you want to modify the resources intall directory. The default installs it along side fs2_open resources.
+resourcesdir=/opt/fs2_open/wxlauncher
+
+depends=('wxpython' 'python2' 'python2-markdown' 'openal')
+optdepends=('fs2_open')
+makedepends=(cmake)
+
+#prepare() {
+#}
+
+
+build() {
+ cd "$srcdir/${_pkgtar}-revision-$pkgver"
+
+ if [ ! -d build ]; then
+ mkdir build
+ fi
+
+ cd build/
+
+ # commence build
+
+ #cmake -DPYTHON_EXECUTABLE=python2 -DUSE_OPENAL=1 -DRESOURCES_PATH=$resourcesdir -DCMAKE_INSTALL_PREFIX=/usr ../
+ cmake -DPYTHON_EXECUTABLE=python2 -DUSE_OPENAL=1 -DRESOURCES_PATH=$resourcesdir -DCMAKE_INSTALL_PREFIX=/usr ../ -DwxWidgets_CONFIG_EXECUTABLE='/usr/bin/wx-config' -DwxWidgets_wxrc_EXECUTABLE='/usr/bin/wxrc'
+ make
+
+
+}
+
+package() {
+ cd "$srcdir/$pkgname-revision-$pkgver/build"
+ make DESTDIR="$pkgdir/" install
+ # need to install the .desktop file and icon
+ cd "$srcdir"
+ install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+}
diff --git a/wxlauncher.desktop b/wxlauncher.desktop
new file mode 100644
index 000000000000..fff8bc081706
--- /dev/null
+++ b/wxlauncher.desktop
@@ -0,0 +1,11 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Version=1.0
+Name=wxlauncher
+GenericName=wxlauncher for OpenSCP
+Exec=wxlauncher
+Icon=wxlauncher
+Terminal=false
+Type=Application
+Categories=Game;
+StartupNotify=true
diff --git a/wxlauncher.install b/wxlauncher.install
new file mode 100644
index 000000000000..98410ffd4552
--- /dev/null
+++ b/wxlauncher.install
@@ -0,0 +1,12 @@
+
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/pixmaps
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/wxlauncher.png b/wxlauncher.png
new file mode 100644
index 000000000000..458dbe23d9c2
--- /dev/null
+++ b/wxlauncher.png
Binary files differ
diff --git a/wxlauncher_homedir.patch b/wxlauncher_homedir.patch
new file mode 100644
index 000000000000..e0772367868f
--- /dev/null
+++ b/wxlauncher_homedir.patch
@@ -0,0 +1,27 @@
+## Description: GetPlatformDefaultConfigFilePath is not a known symbol. As it is defined as inline just inline it manually.
+## Origin/Author: Christoph Korn
+## Bug: https://code.google.com/p/wxlauncher/issues/detail?id=93
+Index: diaspora-1.0.4/Diaspora/wxlauncher/code/apis/PlatformProfileManagerShared.cpp
+===================================================================
+--- diaspora-1.0.4.orig/Diaspora/wxlauncher/code/apis/PlatformProfileManagerShared.cpp 2013-02-14 18:53:15.000000000 +0100
++++ diaspora-1.0.4/Diaspora/wxlauncher/code/apis/PlatformProfileManagerShared.cpp 2013-02-15 19:24:08.319338488 +0100
+@@ -39,8 +39,10 @@
+
+ wxString cmdLineString;
+ #if IS_LINUX // write to folder in home dir
+- extern wxFileName GetPlatformDefaultConfigFilePath();
+- cmdLineString += GetPlatformDefaultConfigFilePath().GetFullPath().c_str();
++ wxFileName path;
++ path.AssignHomeDir();
++ path.AppendDir(_T(".fs2_open"));
++ cmdLineString += path.GetFullPath().c_str();
+ #else
+ cmdLineString += tcPath.c_str();
+ cmdLineString += wxFileName::GetPathSeparator();
+@@ -117,4 +119,4 @@
+ }
+
+ return ProMan::NoError;
+-}
+\ No newline at end of file
++}