summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD7
-rw-r--r--wxlauncher_homedir.patch27
2 files changed, 4 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a9c267faba1..a3b4a296fda8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,12 @@
pkgname=wxlauncher
_pkgtar=wxLauncher
pkgver=0.10.1
-pkgrel=1
+pkgrel=2
-source=("https://github.com/scp-fs2open/wxLauncher/archive/release-${pkgver}.zip"
+source=("https://github.com/wxLauncher/wxlauncher/archive/release-${pkgver}.zip"
"wxlauncher.png"
"wxlauncher.desktop")
+
sha256sums=('aaf721fb44eb23362da92e243ea62e9dc6d9ba80064579d66d9c411f3430327e'
'e3bf9cbe7c61378026331a21313fccd891b051e949448715625d1cfd3ae72576'
'8de688171c12fdf273ece4f33177fd773395204c81cf212f8c4293f0ddd16582')
@@ -20,7 +21,7 @@ license=(GPL2)
# change below if you want to modify the resources intall directory. The default installs it along side fs2_open resources.
resourcesdir=/opt/fs2_open/wxlauncher
-depends=('wxpython' 'python2' 'python2-markdown' 'openal')
+depends=('wxpython' 'python2' 'python2-markdown' 'openal' 'sdl2')
optdepends=('fs2_open')
makedepends=(cmake)
diff --git a/wxlauncher_homedir.patch b/wxlauncher_homedir.patch
deleted file mode 100644
index e0772367868f..000000000000
--- a/wxlauncher_homedir.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-## Description: GetPlatformDefaultConfigFilePath is not a known symbol. As it is defined as inline just inline it manually.
-## Origin/Author: Christoph Korn
-## Bug: https://code.google.com/p/wxlauncher/issues/detail?id=93
-Index: diaspora-1.0.4/Diaspora/wxlauncher/code/apis/PlatformProfileManagerShared.cpp
-===================================================================
---- diaspora-1.0.4.orig/Diaspora/wxlauncher/code/apis/PlatformProfileManagerShared.cpp 2013-02-14 18:53:15.000000000 +0100
-+++ diaspora-1.0.4/Diaspora/wxlauncher/code/apis/PlatformProfileManagerShared.cpp 2013-02-15 19:24:08.319338488 +0100
-@@ -39,8 +39,10 @@
-
- wxString cmdLineString;
- #if IS_LINUX // write to folder in home dir
-- extern wxFileName GetPlatformDefaultConfigFilePath();
-- cmdLineString += GetPlatformDefaultConfigFilePath().GetFullPath().c_str();
-+ wxFileName path;
-+ path.AssignHomeDir();
-+ path.AppendDir(_T(".fs2_open"));
-+ cmdLineString += path.GetFullPath().c_str();
- #else
- cmdLineString += tcPath.c_str();
- cmdLineString += wxFileName::GetPathSeparator();
-@@ -117,4 +119,4 @@
- }
-
- return ProMan::NoError;
--}
-\ No newline at end of file
-+}