summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcb2124a33a8..8773157328ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,22 @@
-# Generated by mksrcinfo v8
-# Tue Dec 15 17:13:27 UTC 2015
pkgbase = wxlauncher
pkgdesc = wxLauncher is a cross-platform launcher for the FreeSpace 2 Open engine
- pkgver = 0.10.1
- pkgrel = 2
- url = http://www.hard-light.net/forums/index.php?topic=67950.0
+ pkgver = 0.11.0
+ pkgrel = 1
+ url = https://github.com/scp-fs2open/wxLauncher
arch = i686
arch = x86_64
license = GPL2
makedepends = cmake
depends = wxpython
- depends = python2
- depends = python2-markdown
+ depends = python
+ depends = python-markdown
depends = openal
depends = sdl2
optdepends = fs2_open
- source = https://github.com/wxLauncher/wxlauncher/archive/release-0.10.1.zip
+ source = https://github.com/scp-fs2open/wxLauncher/archive/release-0.11.0.zip
source = wxlauncher.png
source = wxlauncher.desktop
- sha256sums = aaf721fb44eb23362da92e243ea62e9dc6d9ba80064579d66d9c411f3430327e
+ sha256sums = 720385b6e0a77afa4ad746ae271a200afcecc74fce173f81c6a4f4aed98f7000
sha256sums = e3bf9cbe7c61378026331a21313fccd891b051e949448715625d1cfd3ae72576
sha256sums = 8de688171c12fdf273ece4f33177fd773395204c81cf212f8c4293f0ddd16582
diff --git a/PKGBUILD b/PKGBUILD
index a3b4a296fda8..efa0d9de3dc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,26 @@
pkgname=wxlauncher
_pkgtar=wxLauncher
-pkgver=0.10.1
-pkgrel=2
+pkgver=0.11.0
+pkgrel=1
-source=("https://github.com/wxLauncher/wxlauncher/archive/release-${pkgver}.zip"
+source=("https://github.com/scp-fs2open/wxLauncher/archive/release-${pkgver}.zip"
"wxlauncher.png"
"wxlauncher.desktop")
-sha256sums=('aaf721fb44eb23362da92e243ea62e9dc6d9ba80064579d66d9c411f3430327e'
+sha256sums=('720385b6e0a77afa4ad746ae271a200afcecc74fce173f81c6a4f4aed98f7000'
'e3bf9cbe7c61378026331a21313fccd891b051e949448715625d1cfd3ae72576'
'8de688171c12fdf273ece4f33177fd773395204c81cf212f8c4293f0ddd16582')
pkgdesc="wxLauncher is a cross-platform launcher for the FreeSpace 2 Open engine"
-url="http://www.hard-light.net/forums/index.php?topic=67950.0"
+url="https://github.com/scp-fs2open/wxLauncher"
+#url="http://www.hard-light.net/forums/index.php?topic=67950.0"
arch=(i686 x86_64)
license=(GPL2)
# change below if you want to modify the resources intall directory. The default installs it along side fs2_open resources.
resourcesdir=/opt/fs2_open/wxlauncher
-depends=('wxpython' 'python2' 'python2-markdown' 'openal' 'sdl2')
+depends=('wxpython' 'python' 'python-markdown' 'openal' 'sdl2')
optdepends=('fs2_open')
makedepends=(cmake)
@@ -41,7 +42,7 @@ build() {
# commence build
#cmake -DPYTHON_EXECUTABLE=python2 -DUSE_OPENAL=1 -DRESOURCES_PATH=$resourcesdir -DCMAKE_INSTALL_PREFIX=/usr ../
- cmake -DPYTHON_EXECUTABLE=python2 -DUSE_OPENAL=1 -DRESOURCES_PATH=$resourcesdir -DCMAKE_INSTALL_PREFIX=/usr ../ -DwxWidgets_CONFIG_EXECUTABLE='/usr/bin/wx-config' -DwxWidgets_wxrc_EXECUTABLE='/usr/bin/wxrc'
+ cmake -DPYTHON_EXECUTABLE=python -DUSE_OPENAL=1 -DRESOURCES_PATH=$resourcesdir -DCMAKE_INSTALL_PREFIX=/usr ../ -DwxWidgets_CONFIG_EXECUTABLE='/usr/bin/wx-config' -DwxWidgets_wxrc_EXECUTABLE='/usr/bin/wxrc'
make