summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--.nvchecker.toml5
-rw-r--r--PKGBUILD67
4 files changed, 46 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca52010cd1e5..4821468b3d5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = wxlua
- pkgdesc = Lua bindings for wxWidgets (Lua 5.3 compatible fork)
- pkgver = 3.0.0.9
+ pkgdesc = Lua bindings for wxWidgets (Lua 5.3+ compatible fork)
+ pkgver = 3.2.0.2
pkgrel = 1
url = https://github.com/pkulchenko/wxlua
arch = i686
arch = x86_64
- license = custom:wxWindows
+ license = wxWindows
checkdepends = cppcheck
makedepends = cmake
depends = desktop-file-utils
- depends = wxgtk2
depends = lua
+ depends = wxwidgets-gtk3
optdepends = webkit2gtk
- source = wxlua-3.0.0.9.tar.gz::https://github.com/pkulchenko/wxlua/archive/v3.0.0.9.tar.gz
- sha256sums = 28c54297824d6691273a6470f0330a5c6dd6c977e30fb533aaf3350d995ec994
+ source = https://github.com/pkulchenko/wxlua/archive/v3.2.0.2/wxlua-3.2.0.2.tar.gz
+ sha256sums = 62abe571803a9748e19e86e39cb0e254fd90a5925dc5f0e35669e693cbdb129e
pkgname = wxlua
-
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 0ca50ff4dd97..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-*
-!./.SRCINFO
-!./.gitignore
-!./PKGBUILD
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..fe4742c5fb7e
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,5 @@
+[wxlua]
+source = "github"
+github = "pkulchenko/wxlua"
+prefix = "v"
+use_max_tag = true
diff --git a/PKGBUILD b/PKGBUILD
index 67f3a09c77ff..f61ba1c4ebea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,46 +5,49 @@
# Contributor: favardin
pkgname=wxlua
-pkgver=3.0.0.9
+pkgver=3.2.0.2
pkgrel=1
-pkgdesc="Lua bindings for wxWidgets (Lua 5.3 compatible fork)"
-arch=('i686' 'x86_64')
+pkgdesc='Lua bindings for wxWidgets (Lua 5.3+ compatible fork)'
+arch=(i686 x86_64)
url="https://github.com/pkulchenko/$pkgname"
-license=('custom:wxWindows')
-depends=('desktop-file-utils' 'wxgtk2' 'lua')
-optdepends=('webkit2gtk')
-makedepends=('cmake')
-checkdepends=('cppcheck')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/pkulchenko/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('28c54297824d6691273a6470f0330a5c6dd6c977e30fb533aaf3350d995ec994')
+license=(wxWindows)
+depends=(desktop-file-utils
+ lua
+ wxwidgets-gtk3)
+optdepends=(webkit2gtk)
+makedepends=(cmake)
+checkdepends=(cppcheck)
+_archive="$pkgname-$pkgver"
+source=("$url/archive/v$pkgver/$_archive.tar.gz")
+sha256sums=('62abe571803a9748e19e86e39cb0e254fd90a5925dc5f0e35669e693cbdb129e')
build() {
- cd "$pkgname-$pkgver/wxLua/build"
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
- -DwxLua_LUA_LIBRARY_USE_BUILTIN=FALSE \
- -DwxLua_LUA_LIBRARY_BUILD_SHARED=TRUE \
- -DwxLua_LUA_LIBRARY="/usr/lib/liblua.so" \
- -DwxLua_LUA_INCLUDE_DIR="/usr/include/lua" \
- -DCMAKE_BUILD_TYPE=Release \
- -DwxWidgets_COMPONENTS="stc;gl;html;aui;adv;core;net;base" \
- -DwxLuaBind_COMPONENTS="stc;gl;html;aui;adv;core;net;base" \
- -DBUILD_SHARED_LIBS=TRUE
- make
+ cd "$_archive/wxLua"
+ cmake -S . -B build \
+ -D CMAKE_BUILD_TYPE=Release \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D wxLua_LUA_LIBRARY_USE_BUILTIN=False \
+ -D wxLua_LUA_LIBRARY_BUILD_SHARED=True \
+ -D wxLua_LUA_LIBRARY='/usr/lib/liblua.so' \
+ -D wxLua_LUA_INCLUDE_DIR='/usr/include' \
+ -D wxWidgets_COMPONENTS='stc;gl;html;aui;adv;core;net;base' \
+ -D wxLuaBind_COMPONENTS='stc;gl;html;aui;adv;core;net;base' \
+ -D BUILD_SHARED_LIBS=True
+ make -C build
}
package() {
- cd "$pkgname-$pkgver/wxLua"
- pushd "build"
- make DESTDIR="$pkgdir/" install
- rm -f "$pkgdir"/usr/bin/lua{,c}
- popd
+ cd "$_archive/wxLua"
+ make -C build DESTDIR="$pkgdir/" install
+ rm -f "$pkgdir"/usr/bin/lua{,c}
- install -d "$pkgdir/usr/lib/lua/5.4"
- mv "$pkgdir"/usr/lib/{lib,lua/5.4/}wx.so
+ install -d "$pkgdir/usr/lib/lua/5.4"
+ mv "$pkgdir/usr/lib/"{lib,lua/5.4/}wx.so
- install -Dm 644 docs/licence.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" docs/licence.txt
+ install -Dm644 -t "$pkgdir/usr/share/icons/" art/wxlualogo.xpm
- pushd distrib/autopackage
- install -Dm644 "$pkgname.desktop" -t "$pkgdir/usr/share/applications/"
- install -Dm644 "$pkgname.xml" -t "$pkgdir/usr/share/mime/packages/"
+ pushd distrib/autopackage
+ install -Dm644 "$pkgname.desktop" -t "$pkgdir/usr/share/applications/"
+ install -Dm644 "$pkgname.xml" -t "$pkgdir/usr/share/mime/packages/"
}