summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD20
-rw-r--r--werror_format_security.patch22
4 files changed, 13 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32b4c396f3d7..d62650ec2094 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wyrmsun
pkgdesc = Real-time strategy game based on history, mythology and fiction
- pkgver = 5.3.5
- pkgrel = 3
+ pkgver = 5.3.6
+ pkgrel = 1
url = https://andrettin.github.io/
arch = i686
arch = x86_64
@@ -19,11 +19,9 @@ pkgbase = wyrmsun
depends = qt5-quickcontrols2
depends = sdl2_mixer
depends = tolua++
- source = wyrmsun-5.3.5.tar.gz::https://github.com/Andrettin/Wyrmsun/archive/v5.3.5.tar.gz
- source = wyrmgus-5.3.5.tar.gz::https://github.com/Andrettin/Wyrmgus/archive/v5.3.5.tar.gz
- source = werror_format_security.patch
- md5sums = f519b26169499e52517196b24813d2ac
- md5sums = 73b2e1bf4e29c0663af23d025c104f7c
- md5sums = 426efa2e8ee8b3ab46736d634599963c
+ source = wyrmsun-5.3.6.tar.gz::https://github.com/Andrettin/Wyrmsun/archive/v5.3.6.tar.gz
+ source = wyrmgus-5.3.6.tar.gz::https://github.com/Andrettin/Wyrmgus/archive/v5.3.6.tar.gz
+ md5sums = fd77be9c4e3c425b0cab35c3545ddbba
+ md5sums = 3210ec84d8ef96d6c352ecc149d4c82c
pkgname = wyrmsun
diff --git a/.gitignore b/.gitignore
index 4e4707ee6df2..4953ee4fc1d1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,6 +6,7 @@ src/
*.bz2
*.gz
*.log
+*.log.*
*.pkg.*
*.tar.*
*.xz
diff --git a/PKGBUILD b/PKGBUILD
index e970703806dc..1704d40aa73e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: MCMic <come@chilliet.eu>
pkgname=wyrmsun
-pkgver=5.3.5
-pkgrel=3
+pkgver=5.3.6
+pkgrel=1
pkgdesc="Real-time strategy game based on history, mythology and fiction"
arch=('i686' 'x86_64')
url="https://andrettin.github.io/"
@@ -19,18 +19,9 @@ depends=('hicolor-icon-theme'
'tolua++')
makedepends=('boost' 'cmake' 'glu')
source=("wyrmsun-${pkgver}.tar.gz::https://github.com/Andrettin/Wyrmsun/archive/v${pkgver}.tar.gz"
- "wyrmgus-${pkgver}.tar.gz::https://github.com/Andrettin/Wyrmgus/archive/v${pkgver}.tar.gz"
- 'werror_format_security.patch')
-md5sums=('f519b26169499e52517196b24813d2ac'
- '73b2e1bf4e29c0663af23d025c104f7c'
- '426efa2e8ee8b3ab46736d634599963c')
-
-prepare() {
- cd "${srcdir}/Wyrmgus-${pkgver}"
- # This patch fixes the compilation error with the -Werror=format_security flag
- # until a new version is released.
- patch src/player/player.cpp "${srcdir}/werror_format_security.patch"
-}
+ "wyrmgus-${pkgver}.tar.gz::https://github.com/Andrettin/Wyrmgus/archive/v${pkgver}.tar.gz")
+md5sums=('fd77be9c4e3c425b0cab35c3545ddbba'
+ '3210ec84d8ef96d6c352ecc149d4c82c')
build() {
cd "${srcdir}/Wyrmgus-${pkgver}"
@@ -40,6 +31,7 @@ build() {
-DWITH_GEOJSON=OFF \
-DCMAKE_C_FLAGS="$CFLAGS -DNDEBUG" \
-DCMAKE_CXX_FLAGS="$CXXFLAGS -DNDEBUG" \
+ -DENABLE_USEGAMEDIR=OFF \
-Wno-dev
cmake --build . --target wyrmgus_main
diff --git a/werror_format_security.patch b/werror_format_security.patch
deleted file mode 100644
index 0f8537f2ed89..000000000000
--- a/werror_format_security.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 0e1f7b365aac401434a94198d6339fcc1f2c815b Mon Sep 17 00:00:00 2001
-From: Andrettin <6322423+Andrettin@users.noreply.github.com>
-Date: Fri, 13 May 2022 06:40:12 +0200
-Subject: [PATCH] Fixed warning in CPlayer::set_enemy_diplomatic_stance_with()
-
----
- src/player/player.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/player/player.cpp b/src/player/player.cpp
-index 56ae1b632..8c0768de7 100644
---- a/src/player/player.cpp
-+++ b/src/player/player.cpp
-@@ -5173,7 +5173,7 @@ void CPlayer::set_enemy_diplomatic_stance_with(CPlayer *player)
- }
- message += this->get_name() + " changed their diplomatic stance with us to enemy";
-
-- CPlayer::GetThisPlayer()->Notify(message.c_str());
-+ CPlayer::GetThisPlayer()->notify(message);
- } else if (this == CPlayer::GetThisPlayer()) {
- std::string message = "We have changed our diplomatic stance with ";
- if (player->uses_definite_article()) {