summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD27
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb54d8d5f172..8249012bb799 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = x264-noffmpeg
pkgdesc = Open Source H264/AVC video encoder (no ffmpeg dependency)
- pkgver = 155.r2917.g0a84d986
- pkgrel = 2
+ pkgver = 157.r2945.g72db4377
+ pkgrel = 1
url = https://www.videolan.org/developers/x264.html
- arch = i686
arch = x86_64
license = GPL
makedepends = git
@@ -17,7 +16,7 @@ pkgbase = x264-noffmpeg
conflicts = libx264
conflicts = libx264-10bit
conflicts = libx264-all
- source = x264-noffmpeg::git+https://git.videolan.org/git/x264.git#commit=0a84d986e7020f8344f00752e3600b9769cc1e85
+ source = git+https://git.videolan.org/git/x264.git#commit=72db437770fd1ce3961f624dd57a8e75ff65ae0b
sha256sums = SKIP
pkgname = x264-noffmpeg
diff --git a/PKGBUILD b/PKGBUILD
index b35aa599fccd..ffe1b06be6b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Maintainer : Daniel Bermond < gmail-com: danielbermond >
# NOTE:
# This package provides both 8 and 10-bit support in a single package.
@@ -8,12 +8,12 @@
# comparison about 8-bit and 10-bit, please see, e.g.:
# https://gist.github.com/l4n9th4n9/4459997
-_commit='0a84d986e7020f8344f00752e3600b9769cc1e85'
+_commit='72db437770fd1ce3961f624dd57a8e75ff65ae0b'
pkgname=x264-noffmpeg
-pkgver=155.r2917.g0a84d986
-pkgrel=2
-arch=('i686' 'x86_64')
+pkgver=157.r2945.g72db4377
+pkgrel=1
+arch=('x86_64')
pkgdesc='Open Source H264/AVC video encoder (no ffmpeg dependency)'
url='https://www.videolan.org/developers/x264.html'
license=('GPL')
@@ -21,11 +21,15 @@ depends=('liblsmash.so')
makedepends=('git' 'nasm' 'l-smash')
provides=('x264' 'libx264' 'libx264.so')
conflicts=('x264' 'libx264' 'libx264-10bit' 'libx264-all')
-source=("$pkgname"::"git+https://git.videolan.org/git/x264.git#commit=${_commit}")
+source=("git+https://git.videolan.org/git/x264.git#commit=${_commit}")
sha256sums=('SKIP')
+prepare() {
+ mkdir -p x264/build-{8,10}bit
+}
+
pkgver() {
- cd "$pkgname"
+ cd x264
local _version
local _revision
@@ -39,10 +43,8 @@ pkgver() {
}
build() {
- mkdir -p "$pkgname"/build-{8,10}bit
-
printf '%s\n' ' -> Building for 8-bit...'
- cd "${pkgname}/build-8bit"
+ cd x264/build-8bit
../configure \
--prefix='/usr' \
--enable-shared \
@@ -56,7 +58,7 @@ build() {
make
printf '%s\n' ' -> Building for 10-bit...'
- cd ../build-10bit
+ cd "${srcdir}/x264/build-10bit"
../configure \
--prefix='/usr' \
--libdir='/usr/lib/x264-10bit' \
@@ -73,10 +75,9 @@ build() {
}
package() {
- cd "$pkgname"
+ cd x264
local _depth
-
for _depth in 10 8
do
printf '%s\n' " -> Installing for ${_depth}-bit..."