summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD13
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7062f388f07..72d213933b40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = x2goclient
pkgdesc = a graphical client (Qt5) for the X2Go system
- pkgver = 4.1.2.2
- pkgrel = 5
+ pkgver = 4.1.2.3
+ pkgrel = 1
url = https://wiki.x2go.org/doku.php
arch = x86_64
+ arch = aarch64
license = GPL2
makedepends = qt5-tools
makedepends = man2html
@@ -18,13 +19,15 @@ pkgbase = x2goclient
depends = libxpm
depends = hicolor-icon-theme
optdepends = xorg-xauth: may be required by X2goservers running a different linux distribution giving MIT-COOKIE errors
- source = https://code.x2go.org/releases/source/x2goclient/x2goclient-4.1.2.2.tar.gz
- source = https://code.x2go.org/releases/source/x2goclient/x2goclient-4.1.2.2.tar.gz.asc
+ source = https://code.x2go.org/releases/source/x2goclient/x2goclient-4.1.2.3.tar.gz
+ source = https://code.x2go.org/releases/source/x2goclient/x2goclient-4.1.2.3.tar.gz.asc
source = reproducible-man-gzip.patch
+ source = 0001-Fix-redefinition-compile-error.patch
validpgpkeys = 9BFBAEE86C0AA5FFBF2207829AF46B3025771B31
validpgpkeys = 1AD23D1B8F087A35AB74BDE9F4A7678C9C6B0B2B
- sha256sums = c9953267c40fa67119ad96a73bacb1f266196da2059f0cdcd1b8d5199421d12a
+ sha256sums = ab8bb3c78d31625c749e42f15f810fe3d242927a15298308c13dea3b915aca3c
sha256sums = SKIP
sha256sums = 8b309f0cc99d89737f47e57b79afdc9cccdd36ca3d0772040b1c3fdc0399a4d2
+ sha256sums = be636e911074b474d66016f7a5f0da5fb1693d59291d585cec73f81f54fd9981
pkgname = x2goclient
diff --git a/PKGBUILD b/PKGBUILD
index 2ab56fb58a78..078883eb61c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Richard Murri <admin@richardmurri.com>
pkgname=x2goclient
-pkgver=4.1.2.2
-pkgrel=5
+pkgver=4.1.2.3
+pkgrel=1
arch=('x86_64' 'aarch64')
license=('GPL2')
url="https://wiki.x2go.org/doku.php"
@@ -16,7 +16,7 @@ depends=('qt5-x11extras' 'qt5-svg'
optdepends=('xorg-xauth: may be required by X2goservers running a different linux distribution giving MIT-COOKIE errors')
source=(https://code.x2go.org/releases/source/${pkgname}/${pkgname}-${pkgver}.tar.gz{,.asc}
reproducible-man-gzip.patch 0001-Fix-redefinition-compile-error.patch)
-sha256sums=('c9953267c40fa67119ad96a73bacb1f266196da2059f0cdcd1b8d5199421d12a'
+sha256sums=('ab8bb3c78d31625c749e42f15f810fe3d242927a15298308c13dea3b915aca3c'
'SKIP'
'8b309f0cc99d89737f47e57b79afdc9cccdd36ca3d0772040b1c3fdc0399a4d2'
'be636e911074b474d66016f7a5f0da5fb1693d59291d585cec73f81f54fd9981')
@@ -29,7 +29,10 @@ export CXXFLAGS+=' -fcommon'
prepare() {
cd ${pkgname}-${pkgver}
sed -i "s:-o root -g root ::" Makefile
- sed -i -e 's/qt4/qt5/' Makefile
+ sed -i 's/qt4/qt5/' Makefile
+ sed -i '/^MAKEOVERRIDES\s*=/ s/=.*$/=/' Makefile
+ sed -i '/^\.MAKEOVERRIDES\s*=/ s/=.*$/=/' Makefile
+ sed -i '/^\.MAKEFLAGS\s*=/ s/=.*$/=/' Makefile
# remove timestamp to solve reproducible build
patch -Np1 -i ../reproducible-man-gzip.patch
@@ -46,4 +49,4 @@ package() {
cd ${pkgbase}-${pkgver}
make PREFIX=/usr DESTDIR="$pkgdir" install_client install_man
-}
+} \ No newline at end of file