summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd7f1f4f87d1..f0f6005c715e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = x3270-git
pkgdesc = IBM 3270 terminal emulator for the X Window System
- pkgver = 4.1alpha7.r2733
- pkgrel = 2
+ pkgver = 4.2pre1.r2775
+ pkgrel = 1
url = http://x3270.bgp.nu/
install = x3270.install
arch = x86_64
- license = BSD
+ license = custom
+ license = MIT
makedepends = imake
makedepends = openssl
makedepends = libx11
@@ -31,4 +32,3 @@ pkgbase = x3270-git
sha256sums = 17850aa5153b728844af4f251d56301281678a701fe32e52f521b45f2dbac9c3
pkgname = x3270-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 1d54f794c616..fa998256b2aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: sardo <sardonimous@hotmail.com>
# Parts copied from x3270 package by tuftedocelot <tuftedocelot@fastmail.fm>
pkgname=x3270-git
-pkgver=4.1alpha7.r2733
-pkgrel=2
+pkgver=4.2pre1.r2775
+pkgrel=1
pkgdesc="IBM 3270 terminal emulator for the X Window System"
arch=('x86_64')
url="http://x3270.bgp.nu/"
-license=('BSD')
+license=('custom' 'MIT')
depends=('libxaw' 'openssl' 'bash')
makedepends=('imake' 'openssl' 'libx11' 'libxaw' 'libxt' 'xbitmaps' 'xorg-bdftopcf')
provides=("x3270")
@@ -30,7 +30,7 @@ pkgver() {
build() {
sed -e 's/<[^>]*>//g' -e 's/\\n/\n/g' $pkgname.license | sed -e 's/\[edit\]//g' -e 's/\\\"/\"/g' -e '/^License for.*$/,$!d' | head --lines -2 > ${pkgname}/LICENSE
cd "${pkgname}"
- ./configure --enable-x3270 --prefix=/usr --sysconfdir=/etc --with-fontdir=/usr/share/fonts/3270
+ ./configure --prefix=/usr --sysconfdir=/etc --with-fontdir=/usr/share/fonts/3270
make || return 1
}
package() {