summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
-rw-r--r--x3dna-dssr.md51
3 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1cf44da93a5c..4afe4814dca6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = x3dna-dssr
pkgdesc = DSSR, an integrated software tool for Dissecting the Spatial Structure of RNA. Please see: http://forum.x3dna.org/site-announcements/download-instructions/
- pkgver = 1.6.5_20170122
+ pkgver = 1.6.5_20170220
pkgrel = 1
url = http://x3dna.org/
arch = x86_64
license = custom
depends = glibc
- source = http://x3dna.bio.columbia.edu/downloads/dssr/linux-64bit/x3dna-dssr
- md5sums = d01be25c6f67ee0097bd51d69f7b1494
+ source = x3dna-dssr.md5
+ md5sums = 39fd2ea0eb60e85f90f5dc2fb937bb59
pkgname = x3dna-dssr
diff --git a/PKGBUILD b/PKGBUILD
index 7b20a6ee0f55..cd418ed67641 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,25 @@
# Maintainer: Tomasz Zok <tomasz.zok [at] gmail.com>
pkgname=x3dna-dssr
-pkgver=1.6.5_20170122
+pkgver=1.6.5_20170220
pkgrel=1
pkgdesc="DSSR, an integrated software tool for Dissecting the Spatial Structure of RNA. Please see: http://forum.x3dna.org/site-announcements/download-instructions/"
arch=('x86_64')
url="http://x3dna.org/"
license=('custom')
depends=('glibc')
-source=("http://x3dna.bio.columbia.edu/downloads/dssr/linux-64bit/x3dna-dssr")
-md5sums=('d01be25c6f67ee0097bd51d69f7b1494')
+source=("${pkgname}.md5")
+md5sums=('39fd2ea0eb60e85f90f5dc2fb937bb59')
package() {
- install -D ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+ if [[ ! -r "../${pkgname}" ]]; then
+ echo 'You must download x3dna-dssr binary on your own from the project webpage'
+ echo 'See: http://forum.x3dna.org/site-announcements/download-instructions/'
+ return 1
+ fi
+ if ! md5sum --quiet --check "${pkgname}.md5"; then
+ echo 'Invalid checksum!'
+ return 1
+ fi
+
+ install -D ../${pkgname} ${pkgdir}/usr/bin/${pkgname}
}
diff --git a/x3dna-dssr.md5 b/x3dna-dssr.md5
new file mode 100644
index 000000000000..ebcd5352b967
--- /dev/null
+++ b/x3dna-dssr.md5
@@ -0,0 +1 @@
+767c3a871cd3f911317385aefac59ae5 ../x3dna-dssr