aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
-rw-r--r--snd-hda-intel-x62.conf1
-rw-r--r--x62-alsa-config.service13
4 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e82384c0e81d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = x62-alsa-hacks
+ pkgdesc = ALSA configuration files / scripts for 51nb X62 notebooks
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://dev.yaki-syndicate.de
+ arch = any
+ license = MIT
+ depends = hda-verb
+ source = snd-hda-intel-x62.conf
+ source = x62-alsa-config.service
+ sha512sums = 2116b6e3521793531999811343777d12e0b8b416756f1f924e46ec67751215bd743018e575621ce7fd4eb2df646b146f8a70a970930a58cd28e105818919068e
+ sha512sums = 9bac780c392503d18be3df0c06b04489d7bfbd79de5336168cdeaa300be0115ec2d64382b3c850c6b2f5833de986c6244ff39225e2ef06e963ab7413f11afd15
+
+pkgname = x62-alsa-hacks
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a88bf28f2631
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Samuel Vincent Creshal <samuel@creshal.de>
+
+pkgname=x62-alsa-hacks
+pkgver=0.0.1
+pkgrel=1
+pkgdesc='ALSA configuration files / scripts for 51nb X62 notebooks'
+arch=('any')
+url='https://dev.yaki-syndicate.de'
+license=('MIT')
+depends=('hda-verb')
+source=(
+ 'snd-hda-intel-x62.conf'
+ 'x62-alsa-config.service'
+)
+sha512sums=(
+ '2116b6e3521793531999811343777d12e0b8b416756f1f924e46ec67751215bd743018e575621ce7fd4eb2df646b146f8a70a970930a58cd28e105818919068e'
+ '9bac780c392503d18be3df0c06b04489d7bfbd79de5336168cdeaa300be0115ec2d64382b3c850c6b2f5833de986c6244ff39225e2ef06e963ab7413f11afd15'
+)
+
+package () {
+ install -m 644 -D snd-hda-intel-x62.conf "${pkgdir}/etc/modprobe.d/snd-hda-intel-x62.conf"
+ install -m 644 -D x62-alsa-config.service "${pkgdir}/usr/lib/systemd/system/x62-alsa-config.service"
+}
+
diff --git a/snd-hda-intel-x62.conf b/snd-hda-intel-x62.conf
new file mode 100644
index 000000000000..17e5002c58f8
--- /dev/null
+++ b/snd-hda-intel-x62.conf
@@ -0,0 +1 @@
+options snd-hda-intel model=auto index=1,0
diff --git a/x62-alsa-config.service b/x62-alsa-config.service
new file mode 100644
index 000000000000..80aaa1bfa82e
--- /dev/null
+++ b/x62-alsa-config.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Correctly set GPIO pins for 51nb X62 sound card
+After=multi-user.target
+
+[Install]
+WantedBy=multi-user.target
+
+[Service]
+Type=oneshot
+ExecStart=/usr/bin/hda-verb /dev/snd/hwC0D0 0x01 SET_GPIO_MASK 0x01
+ExecStart=/usr/bin/hda-verb /dev/snd/hwC0D0 0x01 SET_GPIO_DIRECTION 0x01
+ExecStart=/usr/bin/hda-verb /dev/snd/hwC0D0 0x01 SET_GPIO_DATA 0x00
+