summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
2 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c24716947bf..39ab2f4092e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xavs2-git
pkgdesc = Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard (git version)
- pkgver = 1.3.r52.geae1e8b
+ pkgver = 1.4.r0.geae1e8b
pkgrel = 1
url = https://github.com/pkuvcl/xavs2/
arch = x86_64
@@ -15,8 +15,8 @@ pkgbase = xavs2-git
conflicts = xavs2
conflicts = libxavs2-git
replaces = libxavs2-git
+ options = !lto
source = git+https://github.com/pkuvcl/xavs2.git
sha256sums = SKIP
pkgname = xavs2-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3fa73affe697..286a6a1a2db2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer: Daniel Bermond <dbermond@archlinux.org>
# NOTE:
-# 10-bit depth currently fails to build
-# https://github.com/pkuvcl/xavs2/issues/9
+# 10-bit depth is not supported currently
+# https://github.com/pkuvcl/xavs2/blob/1.4/build/linux/configure#L500
pkgname=xavs2-git
-_srcname=xavs2
-pkgver=1.3.r52.geae1e8b
+pkgver=1.4.r0.geae1e8b
pkgrel=1
arch=('x86_64')
pkgdesc='Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard (git version)'
@@ -17,35 +16,29 @@ makedepends=('git' 'nasm' 'l-smash')
provides=('xavs2' 'libxavs2-git')
conflicts=('xavs2' 'libxavs2-git')
replaces=('libxavs2-git')
+options=('!lto')
source=('git+https://github.com/pkuvcl/xavs2.git')
sha256sums=('SKIP')
pkgver() {
- cd "$_srcname"
-
- # git, tags available
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+ git -C xavs2 describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd "${_srcname}/build/linux"
-
+ cd xavs2/build/linux
./configure \
--prefix='/usr' \
- --extra-ldflags='-Wl,-z,noexecstack' \
--enable-shared \
--bit-depth='8' \
--chroma-format='all' \
- --enable-lto \
--enable-pic \
--disable-swscale \
--disable-lavf \
--disable-ffms \
--disable-gpac
-
make
}
package() {
- make -C "${_srcname}/build/linux" DESTDIR="$pkgdir" install-cli install-lib-shared
+ make -C xavs2/build/linux DESTDIR="$pkgdir" install-cli install-lib-shared
}