summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56e7d9421cd7..57a55cf1a188 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xavs2-git
pkgdesc = Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard (git version)
pkgver = 1.0.r136.gdc1894c
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pkuvcl/xavs2/
arch = i686
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = xavs2-git
conflicts = xavs2
conflicts = libxavs2-git
replaces = libxavs2-git
- source = xavs2-git::git+https://github.com/pkuvcl/xavs2.git
+ source = git+https://github.com/pkuvcl/xavs2.git
sha256sums = SKIP
pkgname = xavs2-git
diff --git a/PKGBUILD b/PKGBUILD
index c32727505a3f..246a4512e962 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,9 @@
# https://github.com/pkuvcl/xavs2/issues/9
pkgname=xavs2-git
+_srcname=xavs2
pkgver=1.0.r136.gdc1894c
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
pkgdesc='Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard (git version)'
url='https://github.com/pkuvcl/xavs2/'
@@ -16,22 +17,22 @@ makedepends=('git' 'gcc7' 'yasm' 'l-smash')
provides=('xavs2' 'libxavs2-git')
conflicts=('xavs2' 'libxavs2-git')
replaces=('libxavs2-git')
-source=("$pkgname"::'git+https://github.com/pkuvcl/xavs2.git')
+source=('git+https://github.com/pkuvcl/xavs2.git')
sha256sums=('SKIP')
prepare() {
- cd "$pkgname"
+ cd "$_srcname"
# use gcc7 (it does not build with gcc8)
sed -i 's/gcc/gcc-7/' build/linux/configure
# must copy the entire source tree or it will not work
cd "$srcdir"
- cp -af "$pkgname" build-8bit
+ cp -af "$_srcname" build-8bit
}
pkgver() {
- cd "$pkgname"
+ cd "$_srcname"
# git, tags available
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'