summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..37743957baf0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = xbanish-timeout-git
+ pkgdesc = Banish the mouse cursor when typing, show it again when the mouse moves. Patched fork with extra features such as timeout, ignorescroll
+ pkgver = 1.5.r4.g0aa1e44
+ pkgrel = 1
+ url = https://github.com/ckath/xbanish-timeout
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = libxfixes
+ depends = libxi
+ provides = xbanish
+ conflicts = xbanish
+ source = xbanish-timeout-git::git+https://github.com/ckath/xbanish-timeout.git
+ md5sums = SKIP
+
+pkgname = xbanish-timeout-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..120a6b57103e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Ckat <ckat@teknik.io>
+pkgname="xbanish-timeout-git"
+pkgver=1.5.r4.g0aa1e44
+pkgrel=1
+pkgdesc="Banish the mouse cursor when typing, show it again when the mouse moves. Patched fork with extra features such as timeout, ignorescroll"
+arch=('i686' 'x86_64')
+url="https://github.com/ckath/xbanish-timeout"
+license=('BSD')
+depends=('libxfixes' 'libxi')
+makedepends=('git')
+conflicts=('xbanish')
+provides=('xbanish')
+source=("$pkgname::git+https://github.com/ckath/xbanish-timeout.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/^v//g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 xbanish $pkgdir/usr/bin/xbanish
+ install -Dm644 xbanish.1 $pkgdir/usr/share/man/man1/xbanish.1
+ install -Dm644 README $pkgdir/usr/share/doc/$pkgname/README
+}
+