summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--001-makefile.patch17
1 files changed, 7 insertions, 10 deletions
diff --git a/001-makefile.patch b/001-makefile.patch
index 20fb6018c4a9..ee27a841dc38 100644
--- a/001-makefile.patch
+++ b/001-makefile.patch
@@ -1,26 +1,24 @@
Description: Use variables in makefile
- Allow Debian defaults to be used for CXX etc.
- xbrz v18 needs C++17
-
+
Author: P Blackman <peter@pblackman.plus.com>
-Last-Update: 2020-08-31
+Last-Update: 2020-11-13
Index: b/Makefile
===================================================================
--- a/Makefile
+++ b/Makefile
-@@ -1,21 +1,19 @@
+@@ -1,19 +1,19 @@
all: xbrzscale
xbrz/xbrz.o: xbrz/xbrz.cpp xbrz/xbrz.h
-- g++ -std=c++11 -c -o xbrz/xbrz.o xbrz/xbrz.cpp -DNDEBUG
+- g++ -std=c++17 -c -o xbrz/xbrz.o xbrz/xbrz.cpp -DNDEBUG
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -std=c++17 -c -o xbrz/xbrz.o xbrz/xbrz.cpp -DNDEBUG
libxbrzscale.o: libxbrzscale.cpp xbrz/xbrz.h
-- g++ -std=c++11 -c -o libxbrzscale.o libxbrzscale.cpp `sdl2-config --cflags`
+- g++ -std=c++17 -c -o libxbrzscale.o libxbrzscale.cpp `sdl2-config --cflags`
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -std=c++17 -c -o libxbrzscale.o libxbrzscale.cpp `sdl2-config --cflags`
xbrzscale.o: xbrzscale.cpp libxbrzscale.h xbrz/xbrz.h
-- g++ -std=c++11 -c -o xbrzscale.o xbrzscale.cpp `sdl2-config --cflags`
+- g++ -std=c++17 -c -o xbrzscale.o xbrzscale.cpp `sdl2-config --cflags`
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -std=c++17 -c -o xbrzscale.o xbrzscale.cpp `sdl2-config --cflags`
libxbrzscale.a: libxbrzscale.o xbrz/xbrz.o
@@ -28,9 +26,8 @@ Index: b/Makefile
xbrzscale: xbrzscale.o libxbrzscale.a
- g++ -o xbrzscale xbrzscale.o libxbrzscale.a -lSDL2_image `sdl2-config --libs`
--#xbrzscale: xbrzscale.o libxbrzscale.o xbrz/xbrz.o
--# g++ -o xbrzscale xbrzscale.o libxbrzscale.o xbrz/xbrz.o -lSDL2_image `sdl2-config --libs`
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o xbrzscale xbrzscale.o libxbrzscale.a -lSDL2_image `sdl2-config --libs`
clean:
rm -vf xbrzscale.o xbrz/xbrz.o libxbrzscale.o libxbrzscale.a xbrzscale
+