summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore7
-rw-r--r--LICENSE17
-rw-r--r--PKGBUILD42
4 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d8692166a1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = xcftools-git
+ pkgdesc = Command line tools for extracting images and information from GIMP XCF files (Git version).
+ pkgver = 1.0.7.r18.196f517
+ pkgrel = 1
+ url = https://github.com/j-jorge/xcftools/
+ arch = x86_64
+ arch = i686
+ license = Custom
+ makedepends = git
+ depends = libpng
+ depends = perl
+ provides = xcftools
+ conflicts = xcftools
+ source = xcftools::git+https://github.com/j-jorge/xcftools.git
+ source = LICENSE
+ sha256sums = SKIP
+ sha256sums = ad91bc83ff4050aca9867ee0d9b5921f8a31fe50d37b9aaf0e260aa0b4e8987a
+
+pkgname = xcftools-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..092475c4d282
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+pkg
+src
+xcftools
+xcftools-git-*.src.tar.gz
+xcftools-git-*.pkg.tar.xz
+.AURINFO
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..5e41e1df1ff6
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,17 @@
+License
+=======
+
+Xcftools is written by Henning Makholm <henning@makholm.net>
+It is hereby in the public domain.
+
+In jurisdictions that do not recognise grants of copyright to the
+public domain: I, the author and (presumably, in those jurisdictions)
+copyright holder, hereby permit anyone to distribute and use this code,
+in source code or binary form, with or without modifications. This
+permission is world-wide and irrevocable.
+
+Of course, I will not be liable for any errors or shortcomings in the
+code, since I give it away without asking any compenstations.
+
+If you use or distribute this code, I would appreciate receiving
+credit for writing it, in whichever way you find proper and customary.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64a8c1186501
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Christopher Arndt <chris -at- chrisarndt -dot- de>
+
+_pkgname=xcftools
+pkgname="${_pkgname}-git"
+pkgver=1.0.7.r18.196f517
+pkgrel=1
+pkgdesc="Command line tools for extracting images and information from GIMP XCF files (Git version)."
+url="https://github.com/j-jorge/xcftools/"
+arch=('x86_64' 'i686')
+license=('Custom')
+depends=('libpng' 'perl')
+makedepends=('git')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/j-jorge/xcftools.git"
+ "LICENSE")
+sha256sums=('SKIP'
+ 'ad91bc83ff4050aca9867ee0d9b5921f8a31fe50d37b9aaf0e260aa0b4e8987a')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ ver=$(grep PACKAGE_VERSION= configure | cut -f 2 -d "'")
+ echo $ver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${srcdir}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: