summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--Makefile40
-rw-r--r--PKGBUILD18
4 files changed, 50 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d20e2e3dbc6..9a61af4fcd8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = xcursor-breeze
- pkgdesc = Breeze cursor theme (KDE Plasma 5). This package is for usage in non-KDE Plasma desktops.
- pkgver = 5.21.1
+ pkgdesc = KDE Plasma 6 'Breeze' cursor theme. This package is for usage in non-KDE Plasma desktops.
+ pkgver = 6.0.4
pkgrel = 1
epoch = 1
- url = https://www.kde.org
+ url = https://kde.org/plasma-desktop
arch = any
- license = GPL
+ license = GPL-2.0-or-later
depends = libxcursor
conflicts = breeze
- source = http://download.kde.org/stable/plasma/5.21.1/breeze-5.21.1.tar.xz
- sha256sums = 65d95562489f2dc66240b690882f467a4a7990885fd7185337a5006709d3b7f5
+ source = http://download.kde.org/stable/plasma/6.0.4/breeze-6.0.4.tar.xz
+ b2sums = 1e54faf316cf5820bd5103b82034931c9ad15538d95ac9962cb6a00268ae0363446276e398bd46c471b0b8236bcafe1cb69d316fd6f8a9fce5e31d5cc67cf70f
pkgname = xcursor-breeze
-
diff --git a/.gitignore b/.gitignore
index 0c603f9bbd7a..72e8ffc0db8a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1 @@
-pkg/
-src/
-*.tar*
-git.sh
+*
diff --git a/Makefile b/Makefile
index 8a02706c1167..6073b72eb45d 100644
--- a/Makefile
+++ b/Makefile
@@ -1,28 +1,56 @@
-all: clean build git install
+.SHELL = /usr/bin/env bash
+NAME = "$(shell grep -m 1 pkgname .SRCINFO | cut -d '=' -f 2 | xargs)"
+URL = "$(shell grep url .SRCINFO | cut -d '=' -f 2 | xargs)"
+VERSION = "$(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | xargs)"
+
+.PHONY: all
+all: build git install
+
+.PHONY: clean
clean:
rm -r src pkg || true
+.PHONY: geninteg
geninteg:
sed -i '/.*sums=(/,$$d' PKGBUILD
makepkg --geninteg >> PKGBUILD
+.PHONY: srcinfo
srcinfo:
makepkg --printsrcinfo > .SRCINFO
+.PHONY: makepkg
makepkg:
- makepkg -s
+ makepkg --syncdeps --force
+.PHONY: build
build: geninteg srcinfo makepkg
+.PHONY: git
git: git_add git_commit
+.PHONY: git_add
git_add:
- git add PKGBUILD .SRCINFO
+ git add PKGBUILD .SRCINFO Makefile
-git_commit: VERSION = $(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')
+.PHONY: git_commit
+git_commit: GIT_STATUS = "$(shell git status --porcelain)"
git_commit:
- git commit -m "Update to ${VERSION}"
+ [ -n ${GIT_STATUS} ] && git commit -m "Update to ${VERSION}"
+.PHONY: install
install:
- makepkg --install
+ makepkg --repackage --install --force
+
+.PHONY: open
+open:
+ xdg-open $(URL)
+
+.PHONY: run
+run:
+ env $(NAME)
+
+.PHONY: test
+test:
+ env $(NAME) --version
diff --git a/PKGBUILD b/PKGBUILD
index 13622939d226..1963890e41e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: goetzc
+# Contributor: Nicola Revelant <nicolarevelant@outlook.com>
# Contributor: Philip Goto <philip.goto@gmail.com>
# Contributor: grimi
pkgname=xcursor-breeze
epoch=1
-pkgver=5.21.1
+pkgver=6.0.4
pkgrel=1
-pkgdesc="Breeze cursor theme (KDE Plasma 5). This package is for usage in non-KDE Plasma desktops."
+pkgdesc="KDE Plasma 6 'Breeze' cursor theme. This package is for usage in non-KDE Plasma desktops."
arch=('any')
-url="https://www.kde.org"
-license=('GPL')
+url="https://kde.org/plasma-desktop"
+license=('GPL-2.0-or-later')
depends=('libxcursor')
conflicts=('breeze')
source=("http://download.kde.org/stable/plasma/${pkgver}/breeze-${pkgver}.tar.xz")
+b2sums=('1e54faf316cf5820bd5103b82034931c9ad15538d95ac9962cb6a00268ae0363446276e398bd46c471b0b8236bcafe1cb69d316fd6f8a9fce5e31d5cc67cf70f')
package() {
- install -dm755 "$pkgdir"/usr/share/icons/
- cp -r "$srcdir"/breeze-${pkgver}/cursors/Breeze/Breeze/ "$pkgdir"/usr/share/icons/
- cp -r "$srcdir"/breeze-${pkgver}/cursors/Breeze_Snow/Breeze_Snow/ "$pkgdir"/usr/share/icons/
+ install -dm755 "$pkgdir/usr/share/icons/"
+ cp -r "$srcdir/breeze-${pkgver}/cursors/Breeze/Breeze/" "$pkgdir/usr/share/icons/"
+ cp -r "$srcdir/breeze-${pkgver}/cursors/Breeze_Light/Breeze_Light/" "$pkgdir/usr/share/icons/"
}
-
-sha256sums=('65d95562489f2dc66240b690882f467a4a7990885fd7185337a5006709d3b7f5')