summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9cfcf8590c3..88217f74955e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xde-menu-git
pkgdesc = XDG compliant menu generator
- pkgver = 0.13.r1.ge567b46
+ pkgver = 0.14.r1.g789ca5a
pkgrel = 1
url = https://github.com/bbidulock/xde-menu
arch = i686
@@ -8,16 +8,15 @@ pkgbase = xde-menu-git
groups = xde-git
license = GPL
makedepends = git
+ makedepends = gdk-pixbuf-xlib
depends = libwnck+-git
depends = libsm
depends = gnome-menus
- depends = gdk-pixbuf-xlib
optdepends = xdg-launch-git: for LW WM launch notification
optdepends = xde-theme: for LW WM style and theme change support
- provides = xde-menu=0.13.r1.ge567b46
+ provides = xde-menu=0.14-1
conflicts = xde-menu
source = xde-menu-git::git+https://github.com/bbidulock/xde-menu.git
md5sums = SKIP
pkgname = xde-menu-git
-
diff --git a/PKGBUILD b/PKGBUILD
index b00360daf75a..35ab9923184a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
pkgname=xde-menu-git
_pkgname=xde-menu
-pkgver=0.13.r1.ge567b46
+pkgver=0.14.r1.g789ca5a
pkgrel=1
pkgdesc="XDG compliant menu generator"
arch=('i686' 'x86_64')
url="https://github.com/bbidulock/xde-menu"
groups=('xde-git')
license=('GPL')
-provides=($_pkgname=$pkgver)
-conflicts=($_pkgname)
-depends=('libwnck+-git' 'libsm' 'gnome-menus' 'gdk-pixbuf-xlib')
-makedepends=('git')
+provides=("${_pkgname}=${pkgver%%.r*}-${pkgrel}")
+conflicts=("${_pkgname}")
+depends=('libwnck+-git' 'libsm' 'gnome-menus')
+makedepends=('git' 'gdk-pixbuf-xlib')
optdepends=('xdg-launch-git: for LW WM launch notification'
'xde-theme: for LW WM style and theme change support')
source=("$pkgname::git+https://github.com/bbidulock/$_pkgname.git")
@@ -20,7 +20,7 @@ md5sums=('SKIP')
pkgver() {
cd $pkgname
- git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+ git describe --long --tags | sed -E 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,-,.,g'
}
prepare() {
@@ -33,13 +33,12 @@ build() {
# gtk2 is using deprecated glib2 declarations
./configure CFLAGS="-Wno-deprecated-declarations $CFLAGS"
# Fight unused direct deps
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
+ sed -i -e "s| -shared | $LDFLAGS\0 |g" -e "s| if test \"\$export_dynamic\" = yes && test -n \"\$export_dynamic_flag_spec\"; then| func_append compile_command \" $LDFLAGS\"\n func_append finalize_command \" $LDFLAGS\"\n\0|" libtool
make CFLAGS="-Wno-deprecated-declarations $CFLAGS"
}
package() {
- cd $pkgname
- make DESTDIR="$pkgdir" install
+ make -C $pkgname DESTDIR="$pkgdir" install
}
# vim: et sw=2: